Bug 13806 - system does not boot due to device-mapper error
system does not boot due to device-mapper error
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Other
All Linux
: P1 high
Assigned To: io_other
https://bugs.launchpad.net/ubuntu/+so...
:
: 13834 (view as bug list)
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-07-21 00:03 UTC by Roman Shtylman
Modified: 2009-08-02 21:35 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31+
Tree: Mainline
Regression: Yes


Attachments

Description Roman Shtylman 2009-07-21 00:03:30 UTC
When trying to boot into any 2.6.31+ kernel my system hangs with the error:

"device-mapper: table: 252:0: sda too small for target"

The above error just keeps getting echoed out to the screen. This did not happen prior to the .31 kernel(s).

/ is on two disks in raid 0. Each disk is 32GB making a total of 64GB for root. There is 37GB of free space on root so free space is not the issue. 

I use dmraid for my multidisk setup, and up until this kernel line, have never experience such an error in booting.

A link to the launchpad (Ubuntu) bug with other users experiencing the same problem:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/398059
Comment 1 Roman Shtylman 2009-07-23 23:13:22 UTC
I have been pointed to a possible patch for the problem:
http://patchwork.kernel.org/patch/33534/
Comment 2 Rafael J. Wysocki 2009-07-27 22:35:59 UTC
Handled-By : Mike Snitzer <snitzer@redhat.com>
Patch : http://patchwork.kernel.org/patch/33534/
Comment 3 Rafael J. Wysocki 2009-08-02 21:31:31 UTC
*** Bug 13834 has been marked as a duplicate of this bug. ***
Comment 4 Rafael J. Wysocki 2009-08-02 21:35:22 UTC
Fixed by commit 5dea271b6d87bd1d79a59c1d5baac2596a841c37 .

Note You need to log in before you can comment on or make changes to this bug.