Bug 13799 - iwl3945 Not Working Properly
iwl3945 Not Working Properly
Status: CLOSED WILL_FIX_LATER
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 high
Assigned To: Reinette Chatre
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-07-19 07:14 UTC by Darren Blaber
Modified: 2010-01-29 20:17 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31 rc
Tree: Mainline
Regression: Yes


Attachments

Description Darren Blaber 2009-07-19 07:14:02 UTC
Using latest git on linus tree, and wireless testing repository also, I get disconnecting frequently, and have to load and unload the driver before I am able to use it again. This 'disconnect' happens at random times, seems to happen a lot more often when there is a lot of network activity going on.
This happens with the latest wireless testing tree with a plain vanilla tree, as well as on Ubuntu Karmic alpha 2 2.6.31-3-generic. This issue did not occur on 2.6.28 for me, seems to be anything after. 

This is in dmesg:
[ 2346.332048] wlan0: no probe response from AP 00:12:17:0e:b1:7c - disassociating
[ 2346.933139] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2346.933150] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2347.432134] iwl3945 0000:0c:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
[ 2347.932150] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2347.932160] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2348.432060] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2348.432071] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2348.936136] iwl3945 0000:0c:00.0: Error sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.
[ 2352.933148] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2352.933158] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2353.432147] iwl3945 0000:0c:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
[ 2353.932100] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2353.932110] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2354.432142] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2354.432153] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2354.932151] iwl3945 0000:0c:00.0: Error sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.
[ 2358.932157] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2358.932168] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2359.432052] iwl3945 0000:0c:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
[ 2359.936144] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2359.936155] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2360.436150] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2360.436160] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2360.936146] iwl3945 0000:0c:00.0: Error sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.
[ 2364.932135] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2364.932145] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2365.432115] iwl3945 0000:0c:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
[ 2365.932150] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2365.932161] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2366.432144] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2366.432155] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
[ 2366.932057] iwl3945 0000:0c:00.0: Error sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.
[ 2367.433066] iwl3945 0000:0c:00.0: Error sending REPLY_RXON: time out after 500ms.
[ 2367.433073] iwl3945 0000:0c:00.0: Error setting new configuration (-110).
Comment 1 John W. Linville 2009-07-20 14:37:04 UTC
Looks like some angry firmware...are you running the latest firmware version?
Comment 2 Reinette Chatre 2009-07-20 21:17:33 UTC
Do the problems always (as above) start after a disassociation?
Comment 3 Darren Blaber 2009-07-20 22:04:26 UTC
Yes, its always after it disconnects, and its not supposed to disconnect. It happens with every and any access point, whether it be 2 feet away or further. This may sound stupid, but is there an easy way of finding out the firmware version I am using?
Comment 4 Darren Blaber 2009-07-21 01:08:58 UTC
Ok, I am using the latest firmware, as listed on http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-3945-ucode-15.32.2.9.tgz, and am still having the issue.  Again, this worked fine with the code that was in kernel 2.6.28.  Surely there has to be someone else with this issue, I am using the E1705 laptop which came with the card.
Comment 5 Rafael J. Wysocki 2009-07-21 21:29:33 UTC
Can you please verify if 2.6.29 and/or 2.6.30 is fine?
Comment 6 Reinette Chatre 2009-07-23 17:42:58 UTC
This is not a regression specific to 2.6.31. This is an intermittent issue that users have encountered in earlier kernels also. We have a bug report (http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1944 ) where this issue was reported against 2.6.29.
Comment 7 Darren Blaber 2009-07-24 02:25:08 UTC
Yes, it seems as if it indeed is the same issue, However, he said it started with 2.6.27, it was perfect for 2.6.26 and 2.6.28 for me.  Anyway, I suppose this bug can be closed as it is a dupe of the one on intellinuxwireless, I still think this is a very important issue and not just an annoyance.  It requires removing and loading the module.  Anyway, if there is anything else I could do, I'll still be here.
Comment 8 Darren Blaber 2009-07-24 02:40:48 UTC
It might be that that bug might not even be related, as I do not receive microcode errors.
Comment 9 Reinette Chatre 2010-01-29 06:26:12 UTC
This bug is stagnating here even though its duplicate in http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1944 is very active. Please note that the issue being discussed there is exactly what you are seeing and does not include microcode errors. 

Are you still experiencing this issue? Since the bug at intellinuxwireless.org is active (currently at 74 comments with most recent made on 2010-01-04), could you please consider closing this bug here and moving your communication there?

I think this move will be of value to you since some of the users in that bug report have found some kernel configuration parameters that resolve the issue.

I took liberty to mark this bug as "resolved will_fix_later" since the "resolved duplicate" status requires a bug number in this bugzilla.

Please feel free to reopen if you do not agree with this action.

Note You need to log in before you can comment on or make changes to this bug.