Bug 13763 - laptop does not shut down if ethernet cable plugged in
laptop does not shut down if ethernet cable plugged in
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2009-07-12 22:50 UTC by zibi
Modified: 2013-04-09 06:23 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.28-13 Ubuntu
Tree: Mainline
Regression: No


Attachments
output of lspci -vxxx, acpidump, dmesg (81.89 KB, text/plain)
2009-07-15 02:04 UTC, zibi
Details
acpidump output (281.26 KB, text/plain)
2009-07-16 23:04 UTC, zibi
Details

Description zibi 2009-07-12 22:50:51 UTC
I have a lenovo x200 with ubuntu and kubuntu 9.04

Since kernel update, now i'm running

2.6.28-13-generic #45-Ubuntu SMP Tue Jun 30 22:12:12 UTC 2009 x86_64 GNU/Linux

, the laptop freeze at the end of the shut process *i.e. after having shown the shut down screen* ONLY if i leave the ethernet cable plugged in. 

It's my first kernel bug report. If any attachement need just tell me.
Have fun
Comment 1 ykzhao 2009-07-13 00:35:24 UTC
Will you please attach the output of acpidump, lspci -vxxx, dmesg?
Will you please double check whether it can be shutdown if there is no ethernet cable?
Thanks.
Comment 2 Zhang Rui 2009-07-13 03:01:05 UTC
does the problem happen before, say in ubuntu 8.04/8.10?
what if you unload the ethernet card driver before shutdown?
Comment 3 zibi 2009-07-15 02:04:55 UTC
Created attachment 22343 [details]
output of lspci -vxxx, acpidump, dmesg

The computer shut downs neatly if ethernet cable is unplugged.
I have this laptop since january 2009 and with ubuntu 8.10 no problems.

In attachment the required infos.

Thanks and good luck.
Z
Comment 4 ykzhao 2009-07-15 03:03:46 UTC
Please get the acpidump by using the root account.

From the description it seems that the ubuntu 8.10 can work well. Will you please use the git-bisect to identify the commit which causes the regression?

thanks.
Comment 5 Zhang Rui 2009-07-15 03:42:30 UTC
(In reply to comment #3)
> The computer shut downs neatly if ethernet cable is unplugged.

I know, but what if you unload your ethernet card driver and leave the cable plugged in?

> I have this laptop since january 2009 and with ubuntu 8.10 no problems.
> 
so 8.10 shuts down well even if the cable is plugged in, right?
Comment 6 zibi 2009-07-15 12:50:26 UTC
Not sure what you mean with unload the ethernet card driver

ifconfig eth0 down  ?

(I guess not. Anyway that doesn't change anything. Can you give me clear instructions on how to unload the card driver? Sorry pretty noobie)

Concerning 8.10. Yes never had such problem on this machine before updating to this kernel version (I did the kernel update when I was already running 9.04). That means that in 8.10 i had no problems with the older kernel versions. I do not know if the very same kernel I'm running now would give problems in the old ubuntu distribution.
Comment 7 ykzhao 2009-07-16 00:33:53 UTC
(In reply to comment #6)
> Not sure what you mean with unload the ethernet card driver
> 
> ifconfig eth0 down  ?
> 
> (I guess not. Anyway that doesn't change anything. Can you give me clear
> instructions on how to unload the card driver? Sorry pretty noobie)
The ethernet driver should be compiled as module. And before you shutdown the laptop, you can unload the ethernet driver by using the command of "modprobe -r modename". For example: it seems that the e1000 ethernet is used. You can unload the e1000 driver by using "modprobe -r e1000".
> 
> Concerning 8.10. Yes never had such problem on this machine before updating to
> this kernel version (I did the kernel update when I was already running 9.04).
> That means that in 8.10 i had no problems with the older kernel versions. I do
> not know if the very same kernel I'm running now would give problems in the old
> ubuntu distribution.
Of course you can try the new kernel on the old distribution.
Thanks.
Comment 8 Zhang Rui 2009-07-16 05:15:52 UTC
please run "modprobe -r e1000e", and shutdown the machine with ethernet cable plugged in.
Comment 9 zibi 2009-07-16 22:56:59 UTC
>please run "modprobe -r e1000e", and shutdown the machine with ethernet cable
>plugged in.

No difference. After the shut down screen I always get a black screen with blinking cursor. 

>Of course you can try the new kernel on the old distribution.
It is the machine I work with. I wouldn't like to intall and re install the os. Sorry

Bests
Comment 10 zibi 2009-07-16 23:04:55 UTC
Created attachment 22381 [details]
acpidump output
Comment 11 ykzhao 2009-07-20 01:51:28 UTC
Hi, Zibi
    It seems that the box can be shutdown on 2.6.28.13 kernel if there is no ethernet cable. But it can't be shutdown if the ethernet cable is plugged.
    Maybe this issue is related with ethernet driver. So this bug will be moved to driver/ethernet category.

Thanks.
Comment 12 zibi 2009-08-07 16:40:33 UTC
After last kernel update, the bug disappeared.

Now I run
2.6.28-14

Bests
Zibi

PS: I mark the thread as resolved.

Note You need to log in before you can comment on or make changes to this bug.