Bug 13728 - 2.6.31-rc2 soft lockups, RPC-related
2.6.31-rc2 soft lockups, RPC-related
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Arnaldo Carvalho de Melo
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-07-06 22:07 UTC by Rafael J. Wysocki
Modified: 2009-07-27 22:24 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-07-06 22:07:09 UTC
Subject    : 2.6.31-rc2 soft lockups; traces point at rpc_wake_up, nfs4_run_state_manager, bit_waitqueue
Submitter  : Paul Collins <paul@burly.ondioline.org>
Date       : 2009-07-05 7:17
References : http://marc.info/?l=linux-kernel&m=124677884816794&w=4
Notify-Also : Ingo Molnar <mingo@elte.hu>
Notify-Also : Trond Myklebust <Trond.Myklebust@netapp.com>

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-07-26 22:40:45 UTC
On Saturday 11 July 2009, Paul Collins wrote:
> "Rafael J. Wysocki" <rjw@sisk.pl> writes:
> 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13728
> > Subject		: 2.6.31-rc2 soft lockups, RPC-related
> > Submitter	: Paul Collins <paul@burly.ondioline.org>
> > Date		: 2009-07-05 7:17 (2 days old)
> > References	: http://marc.info/?l=linux-kernel&m=124677884816794&w=4
> 
> Still present as of 2.6.31-rc2-00257-gc2cc49a.
> 
> I tried reverting 3f09df70e3a33590ae5a97b8a15486d3711c7065 ("NFS: Ensure
> we always hold the BKL when dereferencing inode->i_flock") to no avail,
> so I guess it's bisection time.
> 
> Attached in case it is useful is dmesg from boot wherein the following
> occurs: 1) I trigger the problem by opening a file on NFS with emacs 2)
> I trigger sysrq-T 3) the softlockup warnings fire 4) I trigger sysrq-T
> again.
> 
> After this all occurred I was still able to perform operations on the
> NFS mount, including playing a movie stored there.
Comment 2 Rafael J. Wysocki 2009-07-27 22:24:28 UTC
On Monday 27 July 2009, Paul Collins wrote:
> "Rafael J. Wysocki" <rjw@sisk.pl> writes:
> 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13728
> > Subject		: 2.6.31-rc2 soft lockups, RPC-related
> > Submitter	: Paul Collins <paul@burly.ondioline.org>
> > Date		: 2009-07-05 7:17 (22 days old)
> > References	: http://marc.info/?l=linux-kernel&m=124677884816794&w=4
> 
> So far it's looking like this problem is no longer present in
> 2.6.31-rc4.

Note You need to log in before you can comment on or make changes to this bug.