Bug 13727 - Cannot Recognize Empty DVD Media
Cannot Recognize Empty DVD Media
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: io_other
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-07-06 22:02 UTC by Rafael J. Wysocki
Modified: 2009-07-12 20:05 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31-rc1-git9
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-07-06 22:02:36 UTC
Subject    : [BUG] Linux-2.6.31-rc1-git9 Cannot Recognize Empty DVD Media
Submitter  : Tarkan Erimer <tarkan.erimer@turknet.net.tr>
Date       : 2009-07-02 16:23
References : http://lkml.org/lkml/2009/7/2/178

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Thomas Meyer 2009-07-08 15:54:19 UTC
Looking at the commit between 2.6.31-rc1 and current master: Try reverting commit 018e0446890661504783f92388ecce7138c1566d (block: get rid of queue-private command filter).

I gave it a try and reverted above commit. Now the empty CD shows up again.
Comment 2 Thomas Meyer 2009-07-11 14:51:16 UTC
Fixed by 76da03467a1a78811777561bbb1fa56175ee4778 (block: call blk_scsi_ioctl_init())

Note You need to log in before you can comment on or make changes to this bug.