Bug 13720 - [2.6.30] Modesetting on Mobility Radeon X700 displays black screen
Summary: [2.6.30] Modesetting on Mobility Radeon X700 displays black screen
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-06 10:47 UTC by Ken Lewis
Modified: 2012-06-12 10:24 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30-rc1
Tree: Mainline
Regression: No


Attachments
dmesg output with r4xx_atom=1 set (26.56 KB, text/plain)
2009-07-06 14:59 UTC, Ken Lewis
Details
verbose lspci output (15.29 KB, text/plain)
2009-07-06 14:59 UTC, Ken Lewis
Details
.config file for kernel build used (50.69 KB, text/plain)
2009-07-06 15:02 UTC, Ken Lewis
Details
video bios file (56.50 KB, application/octet-stream)
2009-07-06 15:19 UTC, Ken Lewis
Details
Fix quirk handling for MSI laptop (2.07 KB, patch)
2009-07-06 15:45 UTC, Alex Deucher
Details | Diff
Dmesg with working KMS output. (28.11 KB, text/plain)
2009-07-06 20:37 UTC, Ken Lewis
Details

Description Ken Lewis 2009-07-06 10:47:02 UTC
Using the new import of Dave Airlie's Radeon KMS DRI driver, my laptop screen (LVDS-connected) goes blank and stays blank while using KMS and modeset=1.

Chip is a Modility Radeon X700 in a MSI Megabook M635 (also known as MS-1029) with a Turion 64 chip running X86-64 userland from Ubuntu (in particular, Karmic Koala and Kubuntu KDE4).  I build my own kernels from mainline to test and will attach dmesg output, Xorg.0.log output (which also apes the Kernel's can't inability to find the LVDS connector -- don't be confused, I'm not complaining about X.org here), and dmesg output.  r4xx_atom does not need to be forced: from reading the source and logs, the chip is identified as ATOMBIOS.

In my own disgnosis, I found that there is a quirk that matches this notebook in driver/gpu/drm/atombios.c but it is not used.  Also, the drm.debug=1 option shows that the VGA and LVDS connectors are identified but no connector is assigned to the LVDS encoder, which I believe is why the screen is blank.
Comment 1 Alex Deucher 2009-07-06 14:12:21 UTC
This is probably a dupe of bug 13683.  r4xx_atom is still a valid option to try.  While r4xx cards have an atombios that atom command tables are not used for programming the mode unless the r4xx_atom option is set.  Please attach your dmesg with the debug option set for the drm module.
Comment 2 Ken Lewis 2009-07-06 14:58:26 UTC
I don't think it's a dupe of that because the reported experience differs: I see no mouse cursor and no powersaving effects correct the lack of an image on-screen.  A bit of googling indicates that my laptop has different hardware -- I'm using ATIIXP audio instead of a Via 82XX (see http://www.linlap.com/wiki/fujitsu+amilo+a1667g).
Comment 3 Ken Lewis 2009-07-06 14:59:17 UTC
Created attachment 22233 [details]
dmesg output with r4xx_atom=1 set
Comment 4 Ken Lewis 2009-07-06 14:59:48 UTC
Created attachment 22234 [details]
verbose lspci output
Comment 5 Ken Lewis 2009-07-06 15:02:12 UTC
Created attachment 22235 [details]
.config file for kernel build used
Comment 6 Ken Lewis 2009-07-06 15:03:09 UTC
Please s/'driver/gpu/drm/atombios.c'/'driver/gpu/drm/radeon/atombios.c'/
Comment 7 Alex Deucher 2009-07-06 15:07:04 UTC
can you attach your video bios?
as root:
cd /sys/bus/pci/devices/0000\:01\:00.0/
echo 1 > rom
cat rom > /tmp/x700_vbios.rom
echo 0 > rom
Comment 8 Ken Lewis 2009-07-06 15:19:50 UTC
Created attachment 22236 [details]
video bios file
Comment 9 Alex Deucher 2009-07-06 15:45:17 UTC
Created attachment 22237 [details]
Fix quirk handling for MSI laptop

This patch should fix the connector enumeration.
Comment 10 Ken Lewis 2009-07-06 20:37:53 UTC
Created attachment 22241 [details]
Dmesg with working KMS output.

The patch Works For Me, against mainline commit 8e4a71.  Thanks so much for the quick turnaround.

WFM SignOff: Ken Lewis.

Note You need to log in before you can comment on or make changes to this bug.