Bug 13715 - ath5k in Master (AP) mode crashes the kernel
ath5k in Master (AP) mode crashes the kernel
Status: CLOSED INSUFFICIENT_DATA
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 high
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-05 19:13 UTC by Andrej Podzimek
Modified: 2010-03-05 16:07 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.29.6, 2.6.30.1
Tree: Mainline
Regression: No


Attachments

Description Andrej Podzimek 2009-07-05 19:13:30 UTC
I tested ath5k in master mode.

Kernel versions I tried:
2.6.29.6
2.6.30.1

Version of hostapd:
0.6.9

This driver has something important in common with ath_pci: They both crash the kernel after a few hours of uptime. ;-)

Amazingly, the kernel crash occurs no matter if the access point is active at that time. Even if I stop hostapd and unload ath5k immediately after bootup, the crash will certainly occur within <5 hours.

It seems that switching ath5k to master mode causes memory corruption.

In most cases, the crash doesn't cause a panic. The whole system freezes so badly that even the magic SysRq key does not help.

I tried netconsole, thinking it could catch some important kernel messages that normally don't get flushed to log files when the crash occurs. Unfortunately, this didn't help. In fact it complicated the whole matter. Switching netconsole on prolonged the uptime considerably, so crashes became too rare... ;-)

Last but not least, the ath5k AP does not work at all. It failed the same way in both kernel versions I tested. When scanned from other machines, there were some weird results, such as zero frequency and "Channel details: INVALID". Stations could assotiate, but authentication failed. The hostapd verbose output did not show any authentication attempts. Stations said authentication timed out.

I used a hostapd configuration that usually works with ath_pci. It's a WPA2 EAP-TLS setup. (The latest versions of ath_pci are limited to about 100 to 200 kbps, which makes the whole network useless. (And they crash the kernel too often as well...) That's why I'm trying to use ath5k instead.)

I'd like to test all this with 2.6.31-rc2, but this version has a serious regression and fails to initialize my AIC-7892P SCSI controller. :-(
Comment 1 Bob Copeland 2009-07-06 18:40:41 UTC
Well, neither 2.6.29 or 2.6.30 even includes AP support for ath5k... so what patches are you carrying?  compat-wireless?

If you can get a serial console up, that would help.  Also, try booting with nmi_watchdog=1 and leave the machine on a text console -- hopefully then you will see a stack trace.  On my hardware, AP mode doesn't cause any crashes, so without a stack trace it's hard to know where to begin.
Comment 2 Bob Copeland 2009-10-25 19:51:30 UTC
Any recent updates?  Does this happen in vanilla 2.6.31?
Comment 3 John W. Linville 2010-03-05 15:59:30 UTC
Closed due to lack of response...

Note You need to log in before you can comment on or make changes to this bug.