Bug 13696 - Reading a DVD crashes the kernel
Summary: Reading a DVD crashes the kernel
Status: RESOLVED DUPLICATE of bug 13399
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: IDE (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: io_ide@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-02 16:46 UTC by Bernardo Dal Seno
Modified: 2009-07-03 12:09 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: No


Attachments
Kernel output (28.09 KB, text/plain)
2009-07-02 16:46 UTC, Bernardo Dal Seno
Details

Description Bernardo Dal Seno 2009-07-02 16:46:47 UTC
Created attachment 22177 [details]
Kernel output

Whenever I insert a DVD in the DVD-ROM drive (/dev/hdc) and try to read it (e.g., mount, dd) the kernel crashes.  The DVD-RW drive works fine.
Attached is the complete kernel output as captured by netconsole, with info about the hardware and the oops dump.

As I'm using Debian, I compiled the vanilla 2.6.30 source using the Debian configuration to make sure the bug doesn't depend on Debian patches.  Kernel 2.6.29 apparently works fine.

If you need any other information, please ask.

Best regards,
Bernardo
Comment 1 Borislav Petkov 2009-07-02 20:07:51 UTC
Looks like a duplicate of Bug 13399. You can try the patch at http://bugzilla.kernel.org/attachment.cgi?id=22042

Thanks,
Boris.
Comment 2 Bernardo Dal Seno 2009-07-03 12:09:49 UTC
Yes, the patch solves the problem.  Thank you.

Sorry for the duplicate; probably when I searched for existing bug reports I thought that a bug found in 2.6.30-rc1 was fixed in 2.6.30 and I didn't check the date.

Best regards,
Bernardo

*** This bug has been marked as a duplicate of bug 13399 ***

Note You need to log in before you can comment on or make changes to this bug.