Bug 13673 - HIGHMEM64G causes hang in PCI init on 32-bit x86
HIGHMEM64G causes hang in PCI init on 32-bit x86
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-06-29 14:14 UTC by Rafael J. Wysocki
Modified: 2009-07-07 11:12 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-06-29 14:14:51 UTC
Subject    : [BUG 2.6.31-rc1] HIGHMEM64G causes hang in PCI init on 32-bit x86
Submitter  : Mikael Pettersson <mikpe@it.uu.se>
Date       : 2009-06-26 15:59
References : http://marc.info/?l=linux-pci&m=124615181602643&w=4
Handled-By : "H. Peter Anvin" <hpa@zytor.com>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 95ee14e4379c5e19c0897c872350570402014742
Author: H. Peter Anvin <hpa@zytor.com>
Date:   Tue Jun 9 18:20:39 2009 -0700

    x86: cap iomem_resource to addressable physical memory

First-Bad-Commit : 95ee14e4379c5e19c0897c872350570402014742
Notify-Also : Grant Grundler <grundler@parisc-linux.org>
Notify-Also : Matthew Wilcox <matthew@wil.cx>
Comment 1 Rafael J. Wysocki 2009-07-07 11:12:16 UTC
On Tuesday 07 July 2009, Mikael Pettersson wrote:
> Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > from 2.6.30.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=3D13673
> > Subject		: HIGHMEM64G causes hang in PCI init on 32-bit x86
> > Submitter	: Mikael Pettersson <mikpe@it.uu.se>
> > Date		: 2009-06-26 15:59 (11 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=3Dlinux/kernel/git/torvalds/linu=
> > x-2.6.git;a=3Dcommit;h=3D95ee14e4379c5e19c0897c872350570402014742
> > References	: http://marc.info/?l=3Dlinux-pci&m=3D124615181602643&w=3D4
> > Handled-By	: H. Peter Anvin <hpa@zytor.com>
> 
> Fixed in 2.6.31-rc2.

Note You need to log in before you can comment on or make changes to this bug.