Bug 13668 - Can't boot 2.6.30 powerpc kernel under qemu.
Can't boot 2.6.30 powerpc kernel under qemu.
Status: CLOSED DOCUMENTED
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-32
All Linux
: P1 normal
Assigned To: platform_ppc-32
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-06-28 23:14 UTC by Rafael J. Wysocki
Modified: 2009-07-07 11:06 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-06-28 23:14:34 UTC
Subject    : Can't boot 2.6.30 powerpc kernel under qemu.
Submitter  : Rob Landley <rob@landley.net>
Date       : 2009-06-27 18:08
References : http://lkml.org/lkml/2009/6/27/159

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.

Bisected down to:

60ee031940c1b09c137b617a8829e2f081961fe0 is first bad commit
commit 60ee031940c1b09c137b617a8829e2f081961fe0
Author: Jeremy Kerr <jk@ozlabs.org>
Date:   Tue Feb 17 11:44:14 2009 +1100

    powerpc/spufs: Use correct return value for spu_handle_mm_fault

    Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
    Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Comment 1 Jeremy Kerr 2009-06-29 01:51:22 UTC
Sent a reply to this on lkml, but looks like I lost the reply-to:

 http://lkml.org/lkml/2009/6/27/175

In short: the config posted on the original mail does not have CONFIG_SPU_BASE, so the only file touched by 60ee031940c1b09c137b617a8829e2f081961fe0 is never compiled.

I'd suggest re-bisecting to find the actual culprit.
Comment 2 Rafael J. Wysocki 2009-07-07 11:06:16 UTC
On Tuesday 07 July 2009, Rob Landley wrote:
> On Monday 06 July 2009 19:01:05 Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.29 and 2.6.30.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.29 and 2.6.30.  Please verify if it still should
> > be listed and let me know (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13668
> > Subject		: Can't boot 2.6.30 powerpc kernel under qemu.
> > Submitter	: Rob Landley <rob@landley.net>
> > Date		: 2009-06-27 18:08 (10 days old)
> > References	: http://lkml.org/lkml/2009/6/27/159
> 
> Resolved, it just required a configuration change.

Note You need to log in before you can comment on or make changes to this bug.