Bug 13665 - commit 69c854817566 causes OOMs
Summary: commit 69c854817566 causes OOMs
Status: CLOSED CODE_FIX
Alias: None
Product: Memory Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Andrew Morton
URL:
Keywords:
Depends on:
Blocks: 13615
  Show dependency tree
 
Reported: 2009-06-28 23:05 UTC by Rafael J. Wysocki
Modified: 2009-07-28 20:54 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-06-28 23:05:17 UTC
Subject    : Found the commit that causes the OOMs
Submitter  : David Howells <dhowells@redhat.com>
Date       : 2009-06-27 08:12
References : http://lkml.org/lkml/2009/6/27/28
Handled-By : Wu Fengguang <fengguang.wu@intel.com>
Patch      : http://patchwork.kernel.org/patch/32740/

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

  commit 69c854817566db82c362797b4a6521d0b00fe1d8
    Author: MinChan Kim <minchan.kim@gmail.com>
    Date:   Tue Jun 16 15:32:44 2009 -0700

    vmscan: prevent shrinking of active anon lru list in case of no swap space V3

First-Bad-Commit : 69c854817566db82c362797b4a6521d0b00fe1d8
Comment 1 Rafael J. Wysocki 2009-07-07 11:09:50 UTC
On Tuesday 07 July 2009, Minchan Kim wrote:
> On Tue,  7 Jul 2009 02:01:03 +0200 (CEST)
> "Rafael J. Wysocki" <rjw@sisk.pl> wrote:
> 
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.30.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> 
> It should be listed.
> 
> I think it is caused by forking process bomb by msgctl11 on LTP. 
> We can refer old
> discussion(http://osdir.com/ml/linux-kernel/2009-07/msg00926.html)
> 
> I think this issue can be solved by 
> dynamic reclaim throttling patch which is making by Rik.
> 
> After he merges it, Let's test again.
Comment 2 Rafael J. Wysocki 2009-07-27 22:18:23 UTC
Patch : http://lkml.org/lkml/2009/7/7/104
Comment 3 Rafael J. Wysocki 2009-07-28 20:54:32 UTC
On Tuesday 28 July 2009, Andrew Morton wrote:
> (cc Rafael)
> 
> On Tue, 28 Jul 2009 09:07:18 +0900 (JST) KOSAKI Motohiro
> <kosaki.motohiro@jp.fujitsu.com> wrote:
> 
> > > 
> > > hm, what ended up happening here?
> > > 
> > > Thanks.
> > 
> > 1) This is NOT regression. the test-case can't run on 1GB machine.
> >    sometimes run successful, another sometimes run failure...
> >    (in later mail, David said old kernel also cause OOM on his machine)
> > 2) However, Rik's patch dramatically reduce OOM risk on this workload.
> > 
> > The last remain problem is: 
> > if highmem is used file caches, userland stack might allocate normal-zone.
> > it can cause OOM.
> > but it is definitely another issue.
> > 
> > dropcache before running msgctl11 solve this issue.
> > 
> > 
> > Conclusion: I agree this bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.