Bug 13661 - Failure to resume from S2R
Failure to resume from S2R
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
Depends on:
Blocks: 7216 13615
  Show dependency treegraph
 
Reported: 2009-06-28 22:45 UTC by Rafael J. Wysocki
Modified: 2009-07-26 23:01 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-06-28 22:45:40 UTC
Subject    : 2.6.31-rc1: warning in smp_call_function_single while S2R
Submitter  : Thomas Meyer <thomas@m3y3r.de>
Date       : 2009-06-27 17:12
References : http://lkml.org/lkml/2009/6/27/80

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Thomas Meyer 2009-06-29 18:23:20 UTC
Reverting commit 1ff6e97f1d993dff2f9b6f4a9173687370660232 ([CPUFREQ] cpumask: avoid playing with cpus_allowed in powernow-k8.c) removes the warning.
Comment 2 Thomas Meyer 2009-07-05 10:35:08 UTC
Ok. One small correction. The computer seems to enter S3 correctly. So the suspend to ram works. BUT the resume from ram seems to get stuck somewhere.
Comment 3 Thomas Meyer 2009-07-07 13:59:31 UTC
Patch in http://lkml.org/lkml/2009/7/7/43 fixes the STR problem for me. I don't care about the warning. Feel free to close this bug.
Comment 4 Rafael J. Wysocki 2009-07-07 20:02:01 UTC
Handled-By : Peter Chubb <peterc@nicta.com.au>
Patch : http://lkml.org/lkml/2009/7/7/43
Comment 5 Rafael J. Wysocki 2009-07-26 23:01:04 UTC
Fixed by commit 00024be9689963c55cf2ab10ce3fb4502016c09a .

Note You need to log in before you can comment on or make changes to this bug.