Bug 13657 - Linux-2.6.31-rc1 Fails To Recognize Some USB Disks
Linux-2.6.31-rc1 Fails To Recognize Some USB Disks
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: io_other
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-06-28 22:30 UTC by Rafael J. Wysocki
Modified: 2009-08-09 23:04 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-06-28 22:30:54 UTC
Subject    : Linux-2.6.31-rc1 Fails To Recognize Some USB Disks
Submitter  : Tarkan Erimer <tarkan.erimer@turknet.net.tr>
Date       : 2009-06-26 10:03
References : http://lkml.org/lkml/2009/6/26/34

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-07-26 21:52:53 UTC
Caused by:

commit 3821d768912a47ddbd6cab52943a8284df88003c
Author: Martin K. Petersen <martin.petersen@oracle.com>
Date:   Sat May 23 11:43:38 2009 -0400

     sd: Detect non-rotational devices

     Detect non-rotational devices and set the queue flag accordingly.

     Signed-off-by: Martin K. Petersen <martin.petersen@oracle.com>
     Signed-off-by: James Bottomley <James.Bottomley@HansenPartnership.com>

First-Bad-Commit : 3821d768912a47ddbd6cab52943a8284df88003c
Handled-By : Martin K. Petersen <martin.petersen@oracle.com>
Comment 2 Martin K. Petersen 2009-08-03 01:45:50 UTC
Workaround is queued in scsi-rc-fixes as ffd4bc2a984fab40ed969163efdff321490e8032.
Comment 4 Rafael J. Wysocki 2009-08-09 23:04:04 UTC
Fixed by commit ffd4bc2a984fab40ed969163efdff321490e8032 .

Note You need to log in before you can comment on or make changes to this bug.