Bug 13656 - 2.6.31-rc1 crashes randomly on my Machine.
2.6.31-rc1 crashes randomly on my Machine.
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-06-28 22:27 UTC by Rafael J. Wysocki
Modified: 2009-08-12 12:36 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31-rc1
Tree: Mainline
Regression: Yes


Attachments
/sys/kernel/debug/kmemleak, kmemleaks from 2.6.31-rc5-00034-ga33a052 (3.46 KB, text/plain)
2009-08-12 12:36 UTC, Zeno R.R. Davatz
Details

Description Rafael J. Wysocki 2009-06-28 22:27:42 UTC
Subject    : 2.6.31-rc1 crashes randomly on my Machine.
Submitter  : Zeno Davatz <zdavatz@gmail.com>
Date       : 2009-06-26 08:56
References : http://lkml.org/lkml/2009/6/26/27

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Zeno R.R. Davatz 2009-07-07 06:29:12 UTC
This issue still remains with 2.6.31-rc2, I pulled from the Linus branch yesterday, recompiled and rebooted from 2.6.31-rc2 - again my X starts (ion-3), the date can not be set and then the machine hangs. Exact same symptoms as in rc1.

Best
Zeno
Comment 2 Zeno R.R. Davatz 2009-07-14 08:00:26 UTC
Just installed 2.6.31-rc3 after pulling from Linus-Git. My machine still hangs after boot. This time ion3 won't start and I directly get a blue screen (I guess some kind of X-Server hang).
Comment 3 Zeno R.R. Davatz 2009-07-27 07:07:39 UTC
Just installed 2.6.31-rc4 after pulling from Linus-Git. Still having the same problem. Right after boot-up and starting X.org the Machine hangs itself. The only way I can reboot is by pulling the power cord or by doing a hard reboot pushing the Power-Button for over 4 seconds.

Once the Kernel hung itself these to lights keep blinking on my keyboard:

http://farm3.static.flickr.com/2441/3760559211_e359b44b06_o.jpg

My X.org runs smooth on 2.6.30
Comment 4 Zeno R.R. Davatz 2009-08-03 06:52:02 UTC
As far as I can tell no more problems. Thanks for the help and the reminders!

Best
Zeno
Comment 5 Rafael J. Wysocki 2009-08-03 14:39:32 UTC
Closing.
Comment 6 Zeno R.R. Davatz 2009-08-12 12:36:05 UTC
Created attachment 22690 [details]
/sys/kernel/debug/kmemleak, kmemleaks from 2.6.31-rc5-00034-ga33a052

This may or may not have to do with the mentioned bug. My system still shows me these errors. That is why I am still posting this here.

The Kernel I am running now is: 2.6.31-rc5-00034-ga33a052

Note You need to log in before you can comment on or make changes to this bug.