Bug 13653 - system hangs after resume from suspend to disk, mce related
system hangs after resume from suspend to disk, mce related
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 13615
  Show dependency treegraph
 
Reported: 2009-06-28 22:13 UTC by Rafael J. Wysocki
Modified: 2009-07-04 21:52 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.30-git16
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-06-28 22:13:24 UTC
Subject    : 2.6.30-git(16 and 17) system hangs after resume from suspend to disk, mce related?
Submitter  : Maciej Rutecki <maciej.rutecki@gmail.com>
Date       : 2009-06-21 19:02
References : http://lkml.org/lkml/2009/6/21/86
Handled-By : Hidetoshi Seto <seto.hidetoshi@jp.fujitsu.com>
Patch      : http://patchwork.kernel.org/patch/32062/
Notify-Also : Andi Kleen <ak@linux.intel.com>

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-06-29 23:29:20 UTC
Patch : http://patchwork.kernel.org/patch/31907/
Ignore-Patch : http://patchwork.kernel.org/patch/32062/
Comment 2 Alan Jenkins 2009-07-02 12:00:27 UTC
My EeePC had a similar problem.  It was hanging immediately on resume from s2ram, and no_console_suspend showed an immediate OOPS in mcheck_init().  The above patch fixed it.

It seems to be fixed in mainline now.  The patch has been committed as  v2.6.30-7781-g7262b6e.  Thanks!
Comment 3 Rafael J. Wysocki 2009-07-04 21:52:30 UTC
Fixed by commit 7262b6e4a4cc18d0f67df145d032c843e4bc382b .

Note You need to log in before you can comment on or make changes to this bug.