Bug 13647 - fb/mmap lockdep report.
fb/mmap lockdep report.
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(Other)
All Linux
: P1 normal
Assigned To: drivers_video-other
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-06-28 21:26 UTC by Rafael J. Wysocki
Modified: 2009-07-07 11:03 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-06-28 21:26:16 UTC
Subject    : 2.6.30 fb/mmap lockdep report.
Submitter  : Dave Jones <davej@redhat.com>
Date       : 2009-06-21 13:33
References : http://lkml.org/lkml/2009/6/21/90

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-06-28 21:28:50 UTC
Notify-Also : Jarek Poplawski <jarkao2@gmail.com>
References : http://lkml.org/lkml/2009/6/21/122

Caused by:

commit 513adb58685615b0b1d47a3f0d40f5352beff189
Author: Andrea Righi <righi.andrea@gmail.com>
Date:   Mon Apr 13 14:39:39 2009 -0700

    fbdev: fix info->lock deadlock in fbcon_event_notify()

First-Bad-Commit : 513adb58685615b0b1d47a3f0d40f5352beff189
Comment 2 Rafael J. Wysocki 2009-07-07 11:03:07 UTC
On Tuesday 07 July 2009, Jarek Poplawski wrote:
> On Tue, Jul 07, 2009 at 02:00:51AM +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.29 and 2.6.30.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.29 and 2.6.30.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13647
> > Subject		: fb/mmap lockdep report.
> > Submitter	: Dave Jones <davej@redhat.com>
> > Date		: 2009-06-21 13:33 (16 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=513adb58685615b0b1d47a3f0d40f5352beff189
> > References	: http://lkml.org/lkml/2009/6/21/90
> > 		  http://lkml.org/lkml/2009/6/21/122
> 
> This lockdep report isn't triggered by 2.6.31-rc2 anymore.

Note You need to log in before you can comment on or make changes to this bug.