Bug 13642 - Kernel bug with dock driver
Kernel bug with dock driver
Status: CLOSED DUPLICATE of bug 13669
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: acpi_platform-drivers@kernel-bugs.osdl.org
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2009-06-28 10:06 UTC by Joerg Platte
Modified: 2013-04-09 06:23 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: No


Attachments
Dmesg with bug (41.41 KB, text/plain)
2009-06-28 10:06 UTC, Joerg Platte
Details

Description Joerg Platte 2009-06-28 10:06:50 UTC
Created attachment 22131 [details]
Dmesg with bug

The bug message found in the dmesg log attached to this bug appears with a high probability - but not always - when I release the eject lever to exchange the drive in the ultrabay slot. I'm not sure if this bug is a regression of 2.6.30, because I did not change the drive in the ultrabay for several months. Maybe it was already in 2.6.29 or before. 

The attached dmesg output already contains a patch from Henrique de Moraes Holschuh that can be found here:
http://patchwork.kernel.org/patch/30864/

Henrique's comment:
Something is causing ACPI devices to have NULL for dev_name().  This broke thinkpad-acpi.
Comment 1 Zhang Rui 2009-06-29 01:18:45 UTC

*** This bug has been marked as a duplicate of bug 13669 ***
Comment 2 Zhang Rui 2009-06-29 01:19:19 UTC
let's work on this bug in bug report #13669. :)
Comment 3 Joerg Platte 2009-07-07 21:40:16 UTC
OK, there's another bug report, hence I'm closing this bug. Furthermore, the bug has been found and fixed by Henrique :)

Note You need to log in before you can comment on or make changes to this bug.