Bug 13592 - Root partition is not found
Root partition is not found
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 high
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-06-21 08:42 UTC by François Valenduc
Modified: 2009-06-30 22:42 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.30-git16
Tree: Mainline
Regression: Yes


Attachments

Description François Valenduc 2009-06-21 08:42:47 UTC
With the current git tree (2.6.30-git16), the root partition is not found. I am using LVM2 and the root partition is one of the logical volumes. After a git bisect run, it appears that the first bad commit is the following:

commit 0c87197142427063e096f11603543ca874045952
Author: Ingo Molnar <mingo@elte.hu>
Date:   Mon Jun 15 11:35:01 2009 +0200

    perf_counter, x86: Improve interactions with fast-gup
Comment 1 François Valenduc 2009-06-30 19:43:32 UTC
This bug is solved in 2.6.31-rc1.
Comment 2 Rafael J. Wysocki 2009-06-30 22:42:11 UTC
On Tuesday 30 June 2009, François Valenduc wrote:
> Rafael J. Wysocki a écrit :
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.30.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13592
> > Subject		: Root partition is not found
> > Submitter	: François Valenduc <francois.valenduc@tvcablenet.be>
> > Date		: 2009-06-21 08:42 (8 days old)
> >
> >
> >
> >   
> In fact, this problem is already solved in 2.6.31-rc1.

Note You need to log in before you can comment on or make changes to this bug.