Bug 13578 - Kernel crash during suspend resume on IBM Thinkpad R52 with Fedora 11
Kernel crash during suspend resume on IBM Thinkpad R52 with Fedora 11
Status: CLOSED DUPLICATE of bug 13269
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: ykzhao
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2009-06-19 06:04 UTC by Terry Barnaby
Modified: 2011-03-03 01:10 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.29.4-167.fc11.i686.PAE
Tree: Fedora
Regression: No


Attachments

Description Terry Barnaby 2009-06-19 06:04:56 UTC
The kernel on my IBM Thinkpad crashes on every resume from suspend with the
following kernel error report:

Previously, your oops was marked with the following description by kernel developers:

[suspend resume] hres_timers_resume() is incorrectly called with interrupts on


The data submitted is shown below:

WARNING: at kernel/hrtimer.c:625 hres_timers_resume+0x34/0x4a() (Not tainted)
Hardware name: 1846AQG
hres_timers_resume() called with IRQs enabled!Modules linked in: fuse rfcomm bridge stp llc bnep sco l2cap nfs lockd nfs_acl auth_rpcgss sunrpc ipv6 cpufreq_ondemand acpi_cpufreq dm_multipath uinput snd_intel8x0 snd_intel8x0m snd_ac97_codec ac97_bus snd_pcm snd_timer ppdev snd firewire_ohci parport_pc iTCO_wdt iTCO_vendor_support ipw2200 video firewire_core parport libipw i2c_i801 yenta_socket rsrc_nonstatic crc_itu_t btusb output tg3 nsc_ircc lib80211 bluetooth soundcore snd_page_alloc irda crc_ccitt pcspkr joydev thinkpad_acpi hwmon ata_generic pata_acpi radeon drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]


Pid: 3497, comm: pm-suspend Not tainted 2.6.29.4-167.fc11.i686.PAE #1
Call Trace:
[<c0435982>] warn_slowpath+0x7c/0xa4
[<c044a2bf>] ? ktime_get_ts+0x4f/0x53
[<c0419b70>] ? lapic_next_event+0x18/0x1c
[<c044ff7a>] ? clockevents_program_event+0xe1/0xf0
[<c0450e09>] ? tick_dev_program_event+0x47/0xb5
[<c0450ed7>] ? tick_program_event+0x26/0x2e
[<c0450428>] ? tick_notify+0x2e8/0x2f7
[<c041fce2>] ? hpet_resume_counter+0x0/0x51
[<c0718f03>] ? notifier_call_chain+0x26/0x48
[<c0449c20>] hres_timers_resume+0x34/0x4a
[<c044dfc8>] timekeeping_resume+0x130/0x138
[<c05eda35>] __sysdev_resume+0x19/0x3d
[<c05eda7f>] sysdev_resume+0x26/0x59
[<c0458b6e>] suspend_devices_and_enter+0x112/0x186
[<c0458d4e>] enter_state+0x142/0x19d
[<c0458e41>] state_store+0x98/0xac
[<c0458da9>] ? state_store+0x0/0xac
[<c0563619>] kobj_attr_store+0x16/0x22
[<c04e6d6d>] sysfs_write_file+0xc9/0xf4
[<c04e6ca4>] ? sysfs_write_file+0x0/0xf4
[<c04a9229>] vfs_write+0x95/0xf4
[<c04a9344>] sys_write+0x4c/0x70
[<c040945f>] sysenter_do_call+0x12/0x34
---[ end trace d20b4a9f72dd2386 ]---
Comment 1 ykzhao 2009-07-13 03:31:56 UTC
It seems that this is a duplicated bug of bug 13558.
thanks.
Comment 2 ykzhao 2009-07-13 03:32:09 UTC

*** This bug has been marked as a duplicate of bug 13558 ***
Comment 3 ykzhao 2009-07-13 05:17:16 UTC
Sorry that it is a duplicated bug of bug 13269 instead of 13558.

Thanks.

*** This bug has been marked as a duplicate of bug 13269 ***

Note You need to log in before you can comment on or make changes to this bug.