Bug 13575 - After S3 resume IDE reports SRST failed (errno=-16)
After S3 resume IDE reports SRST failed (errno=-16)
Status: CLOSED UNREPRODUCIBLE
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 high
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-06-18 18:39 UTC by warpme
Modified: 2010-12-08 20:08 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: Yes


Attachments
LOG from suspend-resume cycle (7.26 KB, application/zip)
2009-06-21 18:08 UTC, warpme
Details
LOG from full, long suspend-resume cycle (7.29 KB, application/octet-stream)
2009-06-30 20:25 UTC, warpme
Details
revert-no-iordy-on-reset.patch (1.34 KB, patch)
2009-07-08 05:13 UTC, Tejun Heo
Details | Diff

Description warpme 2009-06-18 18:39:27 UTC
After resume from S3 IDE reports SRST failed (errno=-16) and HDD LED is always ON.
Workaround is change jumper from CableSelect to Master, but in this case HDD LED is always OFF.
All was OK with previous kernels (tested 2.6.28.10, 2.6.27.18 and 2.6.25.5)

HW is:
-MSI K9N2GM (Nvidia MCP77 IGP8200)
-LIteON DVD-RW PATA
LiteOn is single IDE device and alone mass-storage (no any HDD in system. Boot via PXE)

br
Comment 1 Bartlomiej Zolnierkiewicz 2009-06-18 18:56:51 UTC
This system uses libata so I'm reassigning the bug-report accordingly.
Comment 2 Tejun Heo 2009-06-19 01:36:01 UTC
Can you please attach the output of dmesg after such event has happened?
Comment 3 warpme 2009-06-21 18:08:54 UTC
Created attachment 22035 [details]
LOG from suspend-resume cycle

Pls find log from suspend-resume cycle.
DVD drive is with cable-select jumper.
HDD LED is still ON, dive is not usable.
br
Comment 4 Tejun Heo 2009-06-29 10:30:43 UTC
Sorry about the delay.  The message is cut short.  Can you please wait about ten minutes after resuming and then run "dmesg" and attach the output?  Thanks.
Comment 5 warpme 2009-06-30 20:24:11 UTC
Here is LOG from full suspend-resume cycle.
Comment 6 warpme 2009-06-30 20:25:45 UTC
Created attachment 22154 [details]
LOG from full, long suspend-resume cycle
Comment 7 Tejun Heo 2009-07-08 05:13:54 UTC
Created attachment 22254 [details]
revert-no-iordy-on-reset.patch

Hmmm... strange.  Does the attached patch make any difference?  Thanks.
Comment 8 warpme 2010-12-08 18:55:55 UTC
Hi !

Problem was with particular drive vendor. I lost this drive and I'm unable verify - but I think problem was solved in newer kernels.
Comment 9 Florian Mickler 2010-12-08 19:38:19 UTC
Ok, if you find out otherwise, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.