Bug 13567 - make deb-pkg produces instalation scripts that fail to run with Ubuntu Karmic
Summary: make deb-pkg produces instalation scripts that fail to run with Ubuntu Karmic
Status: CLOSED OBSOLETE
Alias: None
Product: Other
Classification: Unclassified
Component: Configuration (show other bugs)
Hardware: All Linux
: P1 enhancement
Assignee: maximilian attems
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-18 13:26 UTC by Pauli
Modified: 2012-06-08 12:05 UTC (History)
3 users (show)

See Also:
Kernel Version: git v2.6.30-6725-g1d89b30
Tree: Mainline
Regression: No


Attachments
fix for Ubuntu Karmic (767 bytes, patch)
2009-06-18 13:26 UTC, Pauli
Details | Diff
Fixed patch (774 bytes, patch)
2009-06-30 13:16 UTC, Pauli
Details | Diff
output of dpkg -i and sh -x (2.74 KB, text/plain)
2009-06-30 16:20 UTC, Pauli
Details
tested patch (1.37 KB, patch)
2009-07-05 18:19 UTC, maximilian attems
Details | Diff

Description Pauli 2009-06-18 13:26:25 UTC
Created attachment 21984 [details]
fix for Ubuntu Karmic

I tryed make deb-pkg in Ubuntu Karmic but packages were broekn so I have to do minor change to the scripts so there isn't errors.

I don't know if this breaks any other deb based systems but at lest it works in Ubuntu for me.
Comment 1 Andrew Morton 2009-06-29 23:02:08 UTC
Assigned to Max, cc Sam.
Comment 2 maximilian attems 2009-06-30 09:34:58 UTC
could you please post the errors you see on install?
Comment 3 Pauli 2009-06-30 13:16:59 UTC
Created attachment 22147 [details]
Fixed patch

export: 6: 2.6.31-rc1-17: bad variable name
dpkg: error processing ../linux-image-2.6.31-rc1_2.6.31-rc1-18_i386.deb (--install):
 subprocess pre-installation script returned error exit status 2
export: 6: 2.6.31-rc1-17: bad variable name

Parameter passed to scripts is like "configure 2.6.31-rc1-18"

PS. Original patch was buggy and here is the fixed one.
Comment 4 maximilian attems 2009-06-30 15:08:47 UTC
please provide full log of

dpkg -i ../linux-image-2.6.31-rc1_2.6.31-rc1-18_i386.deb

sh -x /var/lib/dpkg/info/linux-image-2.6.31-rc1-18-i386.preinst
sh -x /var/lib/dpkg/info/linux-image-2.6.31-rc1-18-i386.postinst

i might didn't get the file name of the preinstall script right, please use tab completion.
thanks.
Comment 5 Pauli 2009-06-30 16:20:29 UTC
Created attachment 22149 [details]
output of dpkg -i and sh -x
Comment 6 maximilian attems 2009-07-05 12:10:06 UTC
ah ok so it seems this nvidia script does something.

please post:
find -type f /etc/kernel
cat /etc/kernel/postinst.d/nvidia-common

if you have other scripts around there please post too.
Comment 7 Pauli 2009-07-05 15:13:40 UTC
export DEB_MAINT_PARAMS=configure 2.6.30-rc1
export: 1: 2.6.30-rc1: bad variable name
Problem is that.
Another fix would be adding export DEB_MAINT_PARAMS="\"$@\""
to builddeb script
Comment 8 maximilian attems 2009-07-05 16:07:58 UTC
please don't search for ways disabling that export,
but post output of:

find -type f /etc/kernel
cat /etc/kernel/postinst.d/nvidia-common
Comment 9 Pauli 2009-07-05 17:04:48 UTC
(In reply to comment #8)
> please don't search for ways disabling that export,
> but post output of:
> 
> find -type f /etc/kernel
> cat /etc/kernel/postinst.d/nvidia-common

It's not about disabling it but fixing the problem where there is multiple parameters fro script which causes export line fail!

I would like to point about that this bug report is strictly about problem where

export VARIABLE=value1 value2

is failing. Only value1 is set to VARIABLE and value2 is considered as new variable name which caused failure because value2 include characters that are disallowed in variable names.

So solution to problems is to make export understand that value1 and value2 both are part of value that should be set to VARIABLE.

PS. the nvidia script never gets called when failure happens if you don't yet understand it.
Comment 10 maximilian attems 2009-07-05 18:19:12 UTC
Created attachment 22221 [details]
tested patch
Comment 11 Pauli 2009-07-06 21:30:22 UTC
(In reply to comment #10)
> Created an attachment (id=22221) [details]
> tested patch

Works for me too. Thanks.

Note You need to log in before you can comment on or make changes to this bug.