Bug 1355 - 2.6 poweroff always fails -- Centrino
Summary: 2.6 poweroff always fails -- Centrino
Status: REJECTED DUPLICATE of bug 3643
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Off (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-10-14 08:31 UTC by mauro morichi
Modified: 2004-11-10 18:01 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.0-test7/test8
Tree: Mainline
Regression: ---


Attachments
dmesg (10.40 KB, application/octet-stream)
2003-10-14 08:35 UTC, mauro morichi
Details
messages log (12.94 KB, application/octet-stream)
2003-10-14 08:44 UTC, mauro morichi
Details
lspci -vv (9.12 KB, application/octet-stream)
2003-10-14 08:47 UTC, mauro morichi
Details
dmidecode (12.54 KB, application/octet-stream)
2003-10-14 08:52 UTC, mauro morichi
Details
acpidmp (84.35 KB, application/octet-stream)
2003-10-14 08:53 UTC, mauro morichi
Details
Patch to shutdown local APIC at poweroff (1.80 KB, patch)
2004-10-20 02:18 UTC, Alexey Starikovskiy
Details | Diff

Description mauro morichi 2003-10-14 08:31:25 UTC
Distribution: slackware 8.1, gcc 3.3.1
Hardware Environment: notebook JOYBOOK BENQ 5000U Intel Centrino 1400
Software Environment:
Problem Description:
Doing poweroff system report ACPI_POWER_OFF CALLED but don't go off. Echoing "5"
in /proc/acpi/sleep system do nothing. No error was reported. The same problems
occours in kernel 2.6.0-test6 (I've not tested the others), but work well in
kernel 2.4.22 and the system power off correctly.

Steps to reproduce:
call poweroff or echo 5 > /proc/acpi/sleep.
Comment 1 mauro morichi 2003-10-14 08:35:34 UTC
Created attachment 1051 [details]
dmesg

latest dmesg
Comment 2 mauro morichi 2003-10-14 08:44:33 UTC
Created attachment 1052 [details]
messages log

the first 2 lines are the last message before system close.... no error was
report on poweroff
Comment 3 mauro morichi 2003-10-14 08:47:26 UTC
Created attachment 1053 [details]
lspci -vv
Comment 4 mauro morichi 2003-10-14 08:52:56 UTC
Created attachment 1054 [details]
dmidecode
Comment 5 mauro morichi 2003-10-14 08:53:28 UTC
Created attachment 1055 [details]
acpidmp
Comment 6 Len Brown 2003-11-13 10:04:55 UTC
Hmm, poweroff worked on this box 2.4.22, but fails in 2.6.0... 
Can you try 2.4.23? 
If it fails, we probably broke all the releases. 
if it works, then this may be 2.6 specific. 
 
thanks, 
-Len 
 
Comment 7 mauro morichi 2003-11-15 12:41:30 UTC
kernel 2.4.23-rc1: shutdown regular - system go down without error.
kernel 2.6.0-test9 including bk20 - system remain up. echo "5" in
/proc/acpi/sleep do nothing (no message, no error). poweroff or init 1 kill all,
close all application, make shutdown regularly, but remain with message
acpi_power_off (same message and no error displayed in al *-bk* o
kenel-2.6-test* tried since now.
tried disable sleep support from kernel - no changes.
tried change acpi modules from static to modular - no changes. System remain
damned on.
ask me every test o logfile you think may be usefull a I'll send to you.
Comment 8 Andrew E. Schulman 2003-11-15 14:55:30 UTC
This appears to be a dup of bug #1141.
Comment 9 Len Brown 2003-12-02 07:09:41 UTC
Mauro, 
can you test 2.4.23-rc2 or later to see that we haven't broken 2.4.23 also (bug #1619) on your 
system? 
 
thanks, 
-Len 
 
Comment 10 mauro morichi 2003-12-04 09:11:02 UTC
tested kernel 2.4.22 (all rc* versions) and kernel 2.4.23 and I've found
something curious: normally all versions work well and system go off, but if I
start kernel 2.6.0-test and then  I reboot with a kernel 2.4.22/23 the  system
fail to poweroff  and remain with a message like 'flushing device hdx'
powerdown. In this case, if I detach all kind of power sources (AC and Battery)
next poweroff with 2.4.22/3 system go down as we expect.
It seems that some register, some information remains active throught the reboot.
Comment 11 Len Brown 2003-12-04 22:29:04 UTC
Good to know that 2.4.22 or 2.4.23 by themselves powerdown properly. 
 
Is it true that any 2.4 or 2.6 kernel booted after a 2.6-reboot fails to power down? 
 
Does 2.6 powedown properly if 2.6 is booted from hard-power-off? 
If so, does the 2.4 or 2.6 kernel booted after that also power down properly? 
 
If yes, then this issue is specific to 2.6 reboot/reset. 
 
thanks, 
-Len 
 
Comment 12 mauro morichi 2003-12-07 12:07:44 UTC
I've made some test powering off different kernel starting from 2.4.22 to
2.6.test11. So this the results:

      first boot    init  off   second boot   init  off
      2.6.0-test11  6     x     2.4.22        0     ok
      2.4.22        0     ok    2.4.22        0     ok
      2.6.0-test11  0     fail  2.4.22        0     ok
      2.6.0-test11  0     fail  2.4.22-rc3    0     ok
      2.4.22-rc3    0     ok    2.4.22-rc3    0     ok
      2.4.22-rc3    0     ok    2.6.0-test11  0     fail
      2.6.0-test11  0     fail  2.4.22-rc4    0     ok
      2.4.22-rc4    0     ok    2.4.22-rc4    0     ok
      2.4.22-rc4    0     ok    2.4.22-rc5    0     ok
      2.4.22-rc5    0     ok    2.4.22-rc5    0     ok
      2.4.22-rc5    0     ok    2.4.22-rc5    0     fail
      2.4.22-rc5    0     fail  2.4.22-rc.5   0     ok
      
                                                                               
                  
kernel 2.4.22 to rc4 ok.
kernel 2.4.22-rc5 do correct off one time yes and one time no.
2.6.xx never do correct off.
Comment 13 Stian Jordet 2003-12-08 16:33:47 UTC
I'm almost embarassed to write in so many acpi-bugs, but have you tried the
patch from here: http://bugme.osdl.org/show_bug.cgi?id=1141#c5
Comment 14 Len Brown 2004-01-20 22:18:38 UTC
re: 2.6 poweroff always failing 
good -- something that is reproducible is easier to debug. 
Does this still happen with recent 2.6? 
 
re: 2.4.22 rc5 sometimes not working, when rc4 always worked. 
Sicne 2.4.23 (and presumably 2.4.24), work, I'm not going to worry about 2.4.22-rc5 
being intermittant. 
 
Comment 15 Stephan Karacson 2004-02-10 09:58:15 UTC
ACER Travelmate 634LC Gentoo 
ALI-Chipset 
 
Yes patch tried, with or without, system doesn't shut down ("acpi_power_off called" 
message) 
Tried 2.6.0, 2.6.1, 2.6.2, 2.6.3 
Works well with all 2.4.XX-versions since 2.4.21 
Comment 16 Luming Yu 2004-02-10 18:27:03 UTC
try kernel option : nolapic

--Luming
Comment 17 Stephan Karacson 2004-02-11 00:52:21 UTC
no success :-( 
Comment 18 Luming Yu 2004-02-11 01:03:54 UTC
how about http://bugzilla.kernel.org/attachment.cgi?id=723&action=view
Comment 19 Stephan Karacson 2004-02-12 04:19:14 UTC
Patcherrors on 2.6.1, but 2.6.3 was patchable, please tell what I have to patch :) 
 
Make kernel 2.6.3 with the patch gives me  errors. 
... 
  CHK     include/linux/compile.h 
  CC      drivers/acpi/hardware/hwsleep.o 
drivers/acpi/hardware/hwsleep.c: In function `acpi_enter_sleep_state': 
drivers/acpi/hardware/hwsleep.c:214: Warnung: unused variable `PM1control' 
drivers/acpi/hardware/hwsleep.c:304: Warnung: label `re_write' defined but not used 
drivers/acpi/hardware/hwsleep.c: In function `acpi_leave_sleep_state': 
drivers/acpi/hardware/hwsleep.c:434: error: `PM1control' undeclared (first use in this 
function) 
drivers/acpi/hardware/hwsleep.c:434: error: (Each undeclared identifier is reported 
only once 
drivers/acpi/hardware/hwsleep.c:434: error: for each function it appears in.) 
drivers/acpi/hardware/hwsleep.c:439: error: label `re_write' used but not defined 
make[3]: *** [drivers/acpi/hardware/hwsleep.o] Fehler 1 
make[2]: *** [drivers/acpi/hardware] Fehler 2 
make[1]: *** [drivers/acpi] Fehler 2 
make: *** [drivers] Fehler 2 
... 
acpi_power_off bug still present, no success :-( 
Comment 20 Moshe Caspi 2004-04-15 04:11:11 UTC
Same problem on an old machine/kernel using APM, kernel 2.6.3. 
Comment 21 Alexey Starikovskiy 2004-09-09 05:51:13 UTC
Could you please check if this problem still exists in latest kernel?
Comment 22 mauro morichi 2004-09-10 00:22:33 UTC
Ok. I think i've fount some hints. 
Compiling the kernel with no apic and no local apic the system go down 
perfectly. 
I tested this solution with kernel 2.6.7 and 2.6.8.1, so the problem is not in 
the acpi core, but, I think, in the relation between acpi and apic. 
 
Comment 23 Len Brown 2004-09-27 22:07:01 UTC
Re: no-APIC poweroff works...
This is interesting, because another submitter above wrote
that "nolapic" made no difference.  perhaps a different failure
on that box...  Can you verify that "nolapic" on an APIC+IOAPIC
enabled kernel also works?

I wonder also if this is involved:
ACPI: BOOT (v001 INSYDE SYS_BOOT 0x00000100 _CSI 0x00010101) @ 0x1f7ffb90

SBF: Simple Boot Flag extension found and enabled.
SBF: Setting boot flags 0x1

since this is an example where some state is preserved across boot.
Comment 24 mauro morichi 2004-10-02 10:47:17 UTC
test about lapic/apic 
 
kernel 2.6.8.1 
gcc 3.4.0 
 
kernel compiled with apic and lapic on by default. 
 
trying boot with: 
 
only noapic: poweroff fail 
only nolapic: poweroff success 
noapic & nolapic: poweroff success 
with apic & lapic: poweroff fail. 
 
from dmesg: 
ACPI: BOOT (v001 INSYDE SYS_BOOT 0x00000100 _CSI 0x00010101) @ 0x1f7ffb90 
 
about ACPI BOOT 
 
 
Comment 25 Alexey Starikovskiy 2004-10-20 02:18:36 UTC
Created attachment 3859 [details]
Patch to shutdown local APIC at poweroff 

Could you please try the following patch? It looks like forcefully enabled APIC
should be disabled before power off...
Comment 26 Len Brown 2004-11-10 18:01:16 UTC

*** This bug has been marked as a duplicate of 3643 ***

Note You need to log in before you can comment on or make changes to this bug.