Bug 13521 - Disable and enable wireless b43 can't enable wireless
Disable and enable wireless b43 can't enable wireless
Status: RESOLVED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 normal
Assigned To: networking_wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-06-12 14:43 UTC by Biru Ionut
Modified: 2009-12-29 22:27 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: Yes


Attachments
dmesg log (1.81 KB, text/plain)
2009-06-12 14:44 UTC, Biru Ionut
Details

Description Biru Ionut 2009-06-12 14:43:30 UTC
Distribution: Archlinux x86_64

Hardware: dell inspiron 1520
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

Kernel ver: 
Linux version 2.6.30-ARCH (root@T-POWA-LX) (gcc version 4.4.0 20090526 (prerelease) (GCC) ) #1 SMP PREEMPT Fri Jun 12 10:46:46 CEST 2009

Latest working kervel: 2.6.28 series.

Problem Description:
i can reproduce it every time.

1. trigger disable button. b43 is detecting this action and is disabling well.
2. trigger enable button. nothing happen. doing that couples of time still the wireless can't be enabled.
3. with the button enabled I've reloaded b43 module. then is entering in a loop like in the log and is stopping only when i trigger disable and then enable button.







latest working version 2.6.28 series.
Comment 1 Biru Ionut 2009-06-12 14:44:26 UTC
Created attachment 21879 [details]
dmesg log
Comment 2 John W. Linville 2009-06-12 15:37:18 UTC
Did you ever try a 2.6.29 kernel?  I'm curious if it was broken there as well?
Comment 3 Biru Ionut 2009-06-12 15:38:08 UTC
yes. i had tried that version and was broken there too.

Note You need to log in before you can comment on or make changes to this bug.