Bug 135 - SB16/Alsa doesn't work
Summary: SB16/Alsa doesn't work
Status: REJECTED INSUFFICIENT_DATA
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Adam Belay
URL:
Keywords:
: 145 985 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-12-03 12:55 UTC by Luke-Jr
Modified: 2005-01-21 14:06 UTC (History)
3 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: ---


Attachments
modules.conf (845 bytes, text/plain)
2002-12-09 04:10 UTC, Luke-Jr
Details

Description Luke-Jr 2002-12-03 12:55:04 UTC
Exact Kernel version: 2.5.50
Hardware Environment: SB16 ISA
Software Environment:
[root@arumekun linux-2.5.50]$ lsmod
Module                  Size  Used by
snd_seq_dummy           1500  0
snd_rtctimer            1184  0
rtc                     7748  1 snd_rtctimer
snd_opl3_synth          7616  0
snd_seq_instr           5504  1 snd_opl3_synth
snd_seq_midi_emul       4980  1 snd_opl3_synth
snd_dummy               4764  1
snd_ainstr_fm           1124  1 snd_opl3_synth
snd_seq                39116  4 snd_seq_dummy snd_opl3_synth snd_seq_instr
snd_seq_midi_emul
nls_cp932              76218  0
lockd                  38720  0
sunrpc                 87860  1 lockd
fat                    35440  0
usbcore                76260  1
snd_opl3_lib            5888  1 snd_opl3_synth
snd_hwdep               3760  1 snd_opl3_lib
snd_sb16_dsp            5696  0
snd_sb_common           8032  1 snd_sb16_dsp
snd_mpu401_uart         3136  0
snd_rawmidi            14032  1 snd_mpu401_uart
snd_seq_device          3772  4 snd_opl3_synth snd_seq snd_opl3_lib snd_rawmidi
tulip                  37968  1 [unsafe]
crc32                    944  2 tulip [unsafe]

Problem Description:
Audio apps appear to recognize the 'dummy' sound card.

Steps to reproduce:
Play MP3 in XMMS
Comment 1 F 2002-12-07 11:12:20 UTC
Can you show your /etc/modules.conf file.
Have you check the "ALSA Soundcard Matrix" ?
http://www.alsa-project.org/alsa-doc/
Have you a "Soundblaster 16" or "Soundblaster 16 ASP" or "Soundblaster 16 PnP" ?
Comment 2 Luke-Jr 2002-12-09 04:08:37 UTC
I wasn't able to figure out much at the website. All I know is the sound card is
a SB16 in a ISA slot. Is there anything in /proc similar to /proc/pci that would
show me more info on it?
Comment 3 Luke-Jr 2002-12-09 04:10:36 UTC
Created attachment 41 [details]
modules.conf
Comment 4 F 2002-12-12 01:23:02 UTC
Sorry for my poor english.
I supose you card is not pnp.

> Is there anything in /proc similar to /proc/pci

I don't thing there is a /proc/isa. However you can see some informations
about Alsa in /proc :
/proc/asound (modules should be loaded)

If your card is not autodetect by Alsa you should provide some informations to
Alsa. You can pick this informations if your card work under Windows or with
Linux 2.4 and oss for exemple (check /proc/interrupts, /proc/ioports, kernel
log, etc...).

RedHat provide sndconfig package that can find the parameters needed by ISA
cards. today, sndconfig only work with oss (i don't know if sndconfig work
with 2.5).

When you know irq, dma, etc... of your card, use parameter module to snd-sb16
to feed this informations:
* port long array (min = 1, max = 8), description "Port # for SB16 driver."
* irq int array (min = 1, max = 8), description "IRQ # for SB16 driver."
etc...
Check :
http://www.alsa-project.org/alsa-doc/doc-php/template.php3?company=Creative+Labs&card=Soundblaster+16&chip=sb16&module=sb16
if you have a soundblaster 16. The matrix of sound cards is :
http://www.alsa-project.org/alsa-doc/

Until you don't have more information of your sound card, you can't say "there
is a bug !".
Comment 5 Luke-Jr 2002-12-17 04:15:49 UTC
[root@arumekun asound]$ cat cards
0 [16             ]: SB16 - Sound Blaster 16
                     Sound Blaster 16 at 0x220, irq 5, dma 1&5
Comment 6 Luke-Jr 2002-12-25 16:07:49 UTC
I have as much info as I can get. If there is any other ways to get info which I
have not already mentioned, let me know. If there isn't, then either the SB16
driver has a bug or there is a bug in the very fact there is no way to get
information on the problem.
Comment 7 Luke-Jr 2002-12-25 16:58:02 UTC
Just tried using the OSS in 2.5.52:
[root@arumekun luke-jr]$ modprobe sb
FATAL: Error inserting sb (/lib/modules/2.5.52/kernel/sound/oss/sb.ko): No such
device

Looks like the kernel is having a problem seeing the card... it works in 2.4.20
though.
Comment 8 Emanuele 2003-04-09 06:53:27 UTC
I use kernel 2.5.67 with ALSA/sb16 built-in.
isapnp detect the card but ALSA doesnt find it.
Comment 9 Zwane Mwaikambo 2003-05-04 07:25:03 UTC
(added Adam to Cc) Adam, know what the status is with ALSA/ISAPNP?
Comment 10 Zwane Mwaikambo 2003-05-04 07:28:29 UTC
*** Bug 145 has been marked as a duplicate of this bug. ***
Comment 11 Luke-Jr 2003-07-30 21:23:33 UTC
*** Bug 985 has been marked as a duplicate of this bug. ***
Comment 12 Luke-Jr 2003-07-30 21:24:43 UTC
This bug still exists in 2.6.0-test2. It is caused by a conflict with the "new" ACPI code 
and can be worked around by appending "acpi=off" to the kernel parameters. This 
conflict does not exist with unpatched 2.4 kernels. 
Comment 13 Nishanth Aravamudan 2004-11-23 16:40:20 UTC
Is anyone still having this problem with 2.6.9? or, even better, 2.6.10-rc2?

Note You need to log in before you can comment on or make changes to this bug.