Bug 13486 - Linux thinks there’s a floppy drive when there’s not. Userland doesn’t appreciate.
Summary: Linux thinks there’s a floppy drive when there’s not. Userland doesn’t apprec...
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: io_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-08 10:46 UTC by Johan Kiviniemi
Modified: 2012-06-08 11:45 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.30-rc8-ubuntu
Tree: Mainline
Regression: No


Attachments
dmesg (44 bytes, text/plain)
2009-06-08 10:46 UTC, Johan Kiviniemi
Details
dmesg (38.71 KB, text/plain)
2009-06-08 10:49 UTC, Johan Kiviniemi
Details

Description Johan Kiviniemi 2009-06-08 10:46:57 UTC
Created attachment 21806 [details]
dmesg

Note: I’m running an Ubuntu kernel. The tree selector did not have an “Ubuntu” or “Other” option.

Since the installation of DeviceKit-disks, the system startup blocks for almost a minute on two of my computers when udev runs /lib/udev/devkit-disks-part-id for fd0.

Neither of the computers in question have a floppy drive, but Linux says:

[    2.467794] Floppy drive(s): fd0 is 1.44M

I probably could workaround the problem by disabling floppy drives in BIOS settings, but one would think the OS could realize a drive doesn’t exist automatically.

% tail -n0 -F /var/log/syslog & time sudo /lib/udev/devkit-disks-part-id /dev/fd0
DKD_MEDIA_AVAILABLE=1
Entering MS-DOS parser (offset=0, size=4096)
Jun  8 13:39:53 virhe kernel: [131622.526230] end_request: I/O error, dev fd0, sector 0
Jun  8 13:40:06 virhe kernel: [131635.590496] end_request: I/O error, dev fd0, sector 0
Jun  8 13:40:06 virhe kernel: [131635.590517] Buffer I/O error on device fd0, logical block 0
read failed (Input/output error)
Exiting MS-DOS parser
Entering Apple parser
Jun  8 13:40:19 virhe kernel: [131648.654322] end_request: I/O error, dev fd0, sector 0
Jun  8 13:40:19 virhe kernel: [131648.654343] Buffer I/O error on device fd0, logical block 0
read failed (Input/output error)
Leaving Apple parser
No known partition table found
No partition table found on /dev/fd0: Input/output error
sudo /lib/udev/devkit-disks-part-id /dev/fd0  0.01s user 0.02s system 0% cpu 52.301 total

Interestingly, lshw does not list a floppy drive at all.
Comment 1 Johan Kiviniemi 2009-06-08 10:49:23 UTC
Created attachment 21807 [details]
dmesg
Comment 2 Alan 2012-06-08 11:45:13 UTC
The kernel actually does check what it can

Note You need to log in before you can comment on or make changes to this bug.