Bug 13483 - ath9k receives PCI FATAL interrupt under 2.6.30
ath9k receives PCI FATAL interrupt under 2.6.30
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Wireless
IA-64 Linux
: P1 normal
Assigned To: networking_wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-06-08 04:13 UTC by Phil Linttell
Modified: 2009-06-28 19:09 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.30-8
Tree: Mainline
Regression: Yes


Attachments
lspci -vvnn (20.61 KB, text/plain)
2009-06-08 04:13 UTC, Phil Linttell
Details

Description Phil Linttell 2009-06-08 04:13:57 UTC
Created attachment 21804 [details]
lspci -vvnn

I'm running ubuntu karmic alpha 1 and with kernel 2.6.30-7 and 2.6.30-8 wireless networking dies shortly after boot-up with the following message in the log:

[ 6163.608689] ath9k: received PCI FATAL interrupt
[ 6167.608585] wlan0: no probe response from AP 00:18:39:6f:60:02 - disassociating

This does not occur under with kernel 2.6.29.2 or 2.6.29.1 on the same system.  I can get networking working again for a short time with:

modprobe -r ath9k
modprobe ath9k
/etc/init.d/networking restart

But it will soon die again with the same message.

My wireless networking has been solid for months, and only fails under 2.6.30.
Comment 1 Phil Linttell 2009-06-16 13:00:04 UTC
Tested as well with my distribution's release of 2.6.30-9.  Same error.  The log below shows that it recovered twice, briefly, but after that seemed to stay down... at least until I rebooted back with 26.6.29.2.

[  234.737624] ath9k: received PCI FATAL interrupt
[  238.736525] wlan0: no probe response from AP 00:18:39:6f:60:02 - disassociating
[  239.608827] wlan0: authenticate with AP 00:18:39:6f:60:02
[  239.611346] wlan0: authenticated
[  239.611356] wlan0: associate with AP 00:18:39:6f:60:02
[  239.615507] wlan0: RX ReassocResp from 00:18:39:6f:60:02 (capab=0x411 status=0 aid=1)
[  239.615516] wlan0: associated
[  369.481780] ath9k: received PCI FATAL interrupt
[  373.480552] wlan0: no probe response from AP 00:18:39:6f:60:02 - disassociating
[  374.325108] wlan0: authenticate with AP 00:18:39:6f:60:02
[  374.329847] wlan0: authenticate with AP 00:18:39:6f:60:02
[  374.332351] wlan0: authenticated
[  374.332357] wlan0: associate with AP 00:18:39:6f:60:02
[  374.339310] wlan0: RX ReassocResp from 00:18:39:6f:60:02 (capab=0x411 status=0 aid=1)
[  374.339315] wlan0: associated
[  486.940779] ath9k: received PCI FATAL interrupt
[  490.936530] wlan0: no probe response from AP 00:18:39:6f:60:02 - disassociating
Comment 2 Jouni Malinen 2009-06-16 13:27:25 UTC
I hit an issue that may be caused by the same issue. This was resolved by reverting an earlier change in ath9k. I've submitted a fix for this and will hopefully be available in wireless-testing.git eventually (and also as a 2.6.30.x stable release). If you have a chance to test the patch by building a modified kernel version yourself, you can find the submission from

http://article.gmane.org/gmane.linux.kernel.wireless.general/34741
Comment 3 Phil Linttell 2009-06-16 16:37:08 UTC
Hi Jouni,

Thanks!  I applied the patch to my distribution's source for 2.6.30-9.  I can confirm that the PCI FATAL error message has gone away and my networking is again stable.  (Posting this now with it running.)

How can I follow the progress of the patch to know when it goes into a stable release?

Phil
Comment 4 Luis R. Rodriguez 2009-06-22 15:39:54 UTC
Can someone please close this bug now?

Note You need to log in before you can comment on or make changes to this bug.