Bug 13470 - Machine doesn't boot due to mmconfig detection problem
Machine doesn't boot due to mmconfig detection problem
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-06-07 11:36 UTC by Rafael J. Wysocki
Modified: 2009-06-28 19:09 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-06-07 11:36:08 UTC
Subject    : Stable regression 2.6.29.3 vs 2.6.29.2
Submitter  : Pascal Terjan <pterjan@mandriva.com>
Date       : 2009-05-29 19:35
References : http://marc.info/?l=linux-kernel&m=124388792118481&w=4
Handled-By : Yinghai Lu <yinghai@kernel.org>
Patch      : http://patchwork.kernel.org/patch/27613/

Caused by:

commit 044cd80942e47b9de0915b627902adf05c52377f
Author: Yinghai Lu <yinghai@kernel.org>
Date:   Sat Apr 18 01:43:46 2009 -0700

    x86/PCI: don't call e820_all_mapped with -1 in the mmconfig case

    e820_all_mapped need end is (addr + size) instead of (addr + size - 1)

    Cc: stable@kernel.org
    Acked-by: Ingo Molnar <mingo@elte.hu>
    Signed-off-by: Yinghai Lu <yinghai@kernel.org>
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>

First-Bad-Commit : 044cd80942e47b9de0915b627902adf05c52377f

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-06-28 19:09:03 UTC
Fixed by commit 75e613cdc7bb2ba3795b1bc3ddf19476c767ba68 .

Note You need to log in before you can comment on or make changes to this bug.