Bug 13465 - system hangs on boot right after after mounting (/), freeing kernel memory & starting init
system hangs on boot right after after mounting (/), freeing kernel memory & ...
Status: CLOSED DOCUMENTED
Product: Other
Classification: Unclassified
Component: Configuration
All Linux
: P1 normal
Assigned To: other_configuration@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-06 05:11 UTC by Stan Senuta Jr.
Modified: 2012-06-08 11:37 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: No


Attachments
My boot dmesg output (15.07 KB, text/plain)
2009-06-06 05:11 UTC, Stan Senuta Jr.
Details

Description Stan Senuta Jr. 2009-06-06 05:11:53 UTC
Created attachment 21776 [details]
My boot dmesg output

Mandriva-2001.1 (ext4 KDE4) init-2.86 will stop my bootup & requires me to press the ctrl-c keys to continue. This happens on my "Asus" motherboard. However, I can run Mandriva-2009.1 (ext4 KDE4) with the same kernel on my "MSI" motherboard & there is no boot hangup.

Kernel-2.6.29 was configured & compiled by me to replace the Mandriva distribution kernel & does not need an "initrd"image. I was using this same kernel with my old Mandriva-2008 (ext3 Kde3) prior to upgrading to Mandriva-2009.1 & it had no problems booting my "Asus" or "MSI" motherboards.

I see there is a Bug# 11544 that is similar. I've tried passing the acpi=off, noapic & nolapic to the kernel but they didn't help. 

I was able to boot by passing the init=/bin/bash option, so it seems the /sbin/init file is ok. Also, I have a seperate /boot ext3 for the "Grub" boot images.

I hope you can resolve this. Thank you
Comment 1 Stan Senuta Jr. 2009-06-06 13:40:26 UTC
I have discovered that my bug# 13465 is probably invalid. The problem was in Mandriva-2009.1 /etc/rc.d/rc.sysinit script.
The script was starting /sbin/readahead & several /sbin/readahead-collector-* scripts ..but for some reason they failed 
& this is why my bootup just hungup until I pressed the ctrl-c keys

The boot error ("creadahead-collector: Error cannot deamonize: interrupted system call") wasn't readable because Mandriva
was using another program called "Speedboot". Once I diabled "Speedboot" & booted the system with kernel option "confirm"
I was able to see the boot error & trace it back to /etc/rc.d/rc.sysinit

To be fair to Mandriva though, some, if not most of the blame for my boot problem is my own fault. The prob
lem wasn't 
even a problem until I cloned a working Mandriva-2009.1 to a new disk & installed that disk into my "Asus" box. The old
configuration which was valid on my "MSI"system just wasn't valid on my "Asus" system.

Here ar the line I comented out in "rc.sysinit" to enable a proreb bootup:

  ##if [ -f /.readahead_collect -a -r /etc/sysconfig/readahead ]; then
  ##    . /etc/sysconfig/readahead
  ##    if [ "x$READAHEAD_COLLECT" == "xyes" -a ! -f /forcefsck -a -x /sbin/readahead-collector ]; then
  ##	   /sbin/readahead-collector
  ##    fi
  ##elif [ -x /sbin/readahead_early ]; then
  ##    /sbin/readahead_early &
  ##fi
 
  ##if [ -x /etc/rc.early.local ]; then
  ##    . /etc/rc.early.local
  ##fi

Sorry for taking up your time. But, maybe my bug report will help someone else experiencing the same problem.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.