Bug 13424 - possible deadlock when doing governor switching
possible deadlock when doing governor switching
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: cpufreq
All Linux
: P1 normal
Assigned To: cpufreq
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-06-01 15:46 UTC by Rafael J. Wysocki
Modified: 2009-07-27 21:35 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.30-rc7
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-06-01 15:46:26 UTC
Subject    : [BUG]cpufreq_ondemand: a recent regression
Submitter  : Shaohua Li <shaohua.li@intel.com>
Date       : 2009-05-31 16:36
References : http://www.spinics.net/lists/cpufreq/msg00711.html
Handled-By : Mathieu Desnoyers <mathieu.desnoyers@polymtl.ca>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-06-29 23:17:08 UTC
References : http://lkml.org/lkml/2009/6/28/405
Comment 2 Rafael J. Wysocki 2009-07-27 21:26:11 UTC
On Monday 27 July 2009, Mathieu Desnoyers wrote:
> It should be fixed now by recents commits to the cpufreq tree, which got
> into mainline:
> 
> 42a06f2166f2f6f7bf04f32b4e823eacdceafdc9
> b253d2b2d28ead6fed012feb54694b3d0562839a
> b14893a62c73af0eca414cfed505b8c09efc613c
> 7d26e2d5e2da37e92c6c7644b26b294dedd8c982
> 37c90e8887efd218dc4af949b7f498ca2da4af9f
> 5a75c82828e7c088ca6e7b4827911dc29cc8e774
> ee88415caf736b89500f16e0a545614541a45005
> 3f4a782b5ce2698b1870b5a7b573cd721d4fce33
> 5e1596f75395e7a402e1059c518e633d2732dcf8
> 
> Mathieu
> 
> 
> * Rafael J. Wysocki (rjw@sisk.pl) wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.29 and 2.6.30.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.29 and 2.6.30.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13424
> > Subject		: possible deadlock when doing governor switching
> > Submitter	: Shaohua Li <shaohua.li@intel.com>
> > Date		: 2009-05-31 16:36 (57 days old)
> > References	: http://www.spinics.net/lists/cpufreq/msg00711.html
> > 		  http://lkml.org/lkml/2009/6/28/405
> > Handled-By	: Mathieu Desnoyers <mathieu.desnoyers@polymtl.ca>

Note You need to log in before you can comment on or make changes to this bug.