Bug 13407 - adb trackpad disappears after suspend to ram
adb trackpad disappears after suspend to ram
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216 13070
  Show dependency treegraph
 
Reported: 2009-05-30 22:03 UTC by Rafael J. Wysocki
Modified: 2009-10-26 18:59 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30-rc1
Tree: Mainline
Regression: Yes


Attachments
my kernel config (52.61 KB, text/plain)
2009-08-26 22:39 UTC, Jan Scholz
Details

Description Rafael J. Wysocki 2009-05-30 22:03:16 UTC
Subject    : [regression] adb trackpad disappears after suspend to ram
Submitter  : Jan Scholz <scholz@fias.uni-frankfurt.de>
Date       : 2009-05-28 7:59
References : http://marc.info/?l=linux-kernel&m=124349762314976&w=4
Handled-By : "Rafael J. Wysocki" <rjw@sisk.pl>
Notify-Also : Benjamin Herrenschmidt <benh@kernel.crashing.org>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-05-30 22:04:29 UTC
First-Bad-Commit : 2ed8d2b3a81bdbb0418301628ccdb008ac9f40b7

Caused by:

commit 2ed8d2b3a81bdbb0418301628ccdb008ac9f40b7
Author: Rafael J. Wysocki <rjw@sisk.pl>
Date:   Mon Mar 16 22:34:06 2009 +0100

    PM: Rework handling of interrupts during suspend-resume
Comment 2 Rafael J. Wysocki 2009-07-28 21:03:41 UTC
On Tuesday 28 July 2009, Jan Scholz wrote:
> Hi,
> 
> The bug is still present in v2.6.31-rc4, it is fixed by commenting out
> {suspend,resume}_device_irqs() in drivers/base/power/main.c
> 
> "Rafael J. Wysocki" <rjw@sisk.pl> writes:
> 
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.29 and 2.6.30.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.29 and 2.6.30.  Please verify if it still should
> > be listed and let me know (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13407
> > Subject		: adb trackpad disappears after suspend to ram
> > Submitter	: Jan Scholz <scholz@fias.uni-frankfurt.de>
> > Date		: 2009-05-28 7:59 (60 days old)
> > References	: http://marc.info/?l=linux-kernel&m=124349762314976&w=4
Comment 3 Rafael J. Wysocki 2009-08-26 22:25:45 UTC
On Thursday 27 August 2009, Jan Scholz wrote:
> 
> The bug is still present in v2.6.31-rc7.
> To make it easier to reproduce, I attached my config to this mail.
> 
> Jan
> 
> "Rafael J. Wysocki" <rjw@sisk.pl> writes:
> 
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.29 and 2.6.30.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.29 and 2.6.30.  Please verify if it still should
> > be listed and let me know (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13407
> > Subject		: adb trackpad disappears after suspend to ram
> > Submitter	: Jan Scholz <scholz@fias.uni-frankfurt.de>
> > Date		: 2009-05-28 7:59 (90 days old)
Comment 4 Jan Scholz 2009-08-26 22:39:10 UTC
Created attachment 22867 [details]
my kernel config
Comment 5 Rafael J. Wysocki 2009-09-27 15:13:30 UTC
Handled-By : Benjamin Herrenschmidt <benh@kernel.crashing.org>
Patch : http://patchwork.kernel.org/patch/49462/
Comment 6 Rafael J. Wysocki 2009-10-26 18:59:16 UTC
Fixed by commit 11a50873ef2b3c1c3fe99a661c22c08f35d93553 .

Note You need to log in before you can comment on or make changes to this bug.