Bug 13393 - Too high cpu load due to acpi
Too high cpu load due to acpi
Status: REJECTED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Config-Processors
All Linux
: P1 normal
Assigned To: Shaohua
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 15:39 UTC by orschiro
Modified: 2009-10-09 02:46 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: No


Attachments
acpidump file (375.44 KB, application/octet-stream)
2009-05-28 12:14 UTC, orschiro
Details
output from lspci -vxxx (11.92 KB, application/octet-stream)
2009-05-31 09:44 UTC, orschiro
Details
interrupts (2.14 KB, application/octet-stream)
2009-05-31 09:47 UTC, orschiro
Details
custom kernel config (89.50 KB, application/octet-stream)
2009-06-01 20:16 UTC, orschiro
Details

Description orschiro 2009-05-27 15:39:06 UTC
Hello guys,

I'm not sure whether everything is just correct with this bug report, because it's my first one I have to make.

I have some problems with my cpu load on my HP Compaq 6510b laptop when acpi is loaded. The load is simply too high even if quite nothing is running in the backgrounf. I made some screenshots using htop to explain that more detailed. I asked already some people from Arch and they think it's a kernel bug.

more information and screenshots are available here:

http://forum.archlinux.de/?page=Postings;id=20;thread=12521

When I deactivate acpi by adding acpi=off to the kernel line all problems seem to be solved but that's no alternative.

So if some information is missing please ask otherwise I would be very thankful if you could solve that problem. :)

Thank you and greets

Robert
Comment 1 orschiro 2009-05-28 12:14:31 UTC
Created attachment 21601 [details]
acpidump file

This acpidump might help you.
Comment 2 ykzhao 2009-05-31 00:45:32 UTC
Will you please also attach the output of lspci -vxxx?
   Thanks.
Comment 3 ykzhao 2009-05-31 00:52:18 UTC
will you please attach the following output?
  grep . /sys/firmware/acpi/interrupts/*
   thanks.
Comment 4 orschiro 2009-05-31 09:44:54 UTC
Created attachment 21653 [details]
output from lspci -vxxx

Once the output from lspci -vxxx
Comment 5 orschiro 2009-05-31 09:47:12 UTC
Created attachment 21654 [details]
interrupts

And once the output of the other command.

I have to thank you for your help :)
Comment 6 ykzhao 2009-05-31 15:23:16 UTC
Hi, Robert
    From the interrupt info in comment #5 and acpidump it seems that this is related with the pcie hotplug.
    Will you please enable the pci hotplug in kernel configuration and see whether the issue still exists?(ACPI Pci hotplug should be set in kernel configuration).
    Thanks.
Comment 7 orschiro 2009-05-31 20:14:08 UTC
At least I tried to load them via putting the modules in the rc.conf of my arch system.

MODULES=(pci_hotplug acpiphp shpchp pciehp [...])

I also wrote that modules in my /etc/mkinitcpio.conf

MODULES="pci_hotplug acpiphp shpchp pciehp"

and then ran 

mkinitcpio -p kernel26

But no success..Do I have to build my own kernel?
Comment 8 ykzhao 2009-06-01 00:45:07 UTC
Will you please compile the pci-hotplug as built-in module?
Thanks.
Comment 9 orschiro 2009-06-01 20:16:24 UTC
Created attachment 21693 [details]
custom kernel config

I tried to build in the modules using this config but no advance yet.

Any further suggestions?

Thanks :)
Comment 10 orschiro 2009-06-06 17:31:10 UTC
Do you guys need more information?

So just ask me.

Regards

orschiro
Comment 11 Shaohua 2009-07-01 03:50:27 UTC
kristen, can you look at this issue. The GPE related to a root port is keeping fire. And this looks like a hotplug issue.
Comment 12 orschiro 2009-07-01 07:47:31 UTC
Can I help you with anything?
Comment 13 Shaohua 2009-08-05 02:15:31 UTC
can you give me the outpug of 'lspci -xxxx' (make sure you have root privlige). Looks BIOS enables SCI for hotplug, but current pciehp driver can't acpi event.
Comment 14 Shaohua 2009-08-05 02:26:02 UTC
Also please attach the dmesg output.
Comment 15 orschiro 2009-08-05 08:55:58 UTC
Hello Shaohua,

I'm afraid but my notebook broke down last week so I'm not able to meet your request.

But thank you for your continous help. 

Best regards
Comment 16 Shaohua 2009-08-05 09:06:55 UTC
hm, ok, let's close this one

Note You need to log in before you can comment on or make changes to this bug.