Bug 13391 - Kernel boot hangs at about every second start when kms is activated
Summary: Kernel boot hangs at about every second start when kms is activated
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P2 normal
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-26 21:47 UTC by Martin Bammer
Modified: 2009-09-18 20:41 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.30-rc7
Tree: Mainline
Regression: No


Attachments
Crashed boot process with activated kms (134.81 KB, image/jpeg)
2009-05-26 21:47 UTC, Martin Bammer
Details
Successful boot with kms (54.39 KB, text/plain)
2009-05-26 21:48 UTC, Martin Bammer
Details
kernel configuration (85.59 KB, application/octet-stream)
2009-05-26 21:49 UTC, Martin Bammer
Details
kernel configuration of 2.6.30-rc5 (85.52 KB, application/octet-stream)
2009-05-26 21:51 UTC, Martin Bammer
Details

Description Martin Bammer 2009-05-26 21:47:25 UTC
Created attachment 21571 [details]
Crashed boot process with activated kms

Since kernel 2.6.30-rc6 the boot process hangs when kms is activated.
Kernel 2.6.30-rc5 never had problems with activated kms.
Magic key sequence is not working. Only pressing the power button for 4 seconds or removing the power work.
Comment 1 Martin Bammer 2009-05-26 21:48:13 UTC
Created attachment 21572 [details]
Successful boot with kms
Comment 2 Martin Bammer 2009-05-26 21:49:41 UTC
Created attachment 21573 [details]
kernel configuration
Comment 3 Martin Bammer 2009-05-26 21:51:01 UTC
Created attachment 21574 [details]
kernel configuration of 2.6.30-rc5
Comment 4 Eric Anholt 2009-05-27 02:27:23 UTC
Could you git bisect the issue?
Comment 5 Martin Bammer 2009-05-29 18:43:17 UTC
I tried to bisect the issue. But unfortunately it fails, because of a reiserfs bug after rc5 which causes the kernel crashing when it mounts the root fs.
But I've found the reason for this issue. I remembered that I compiled rc5 with a slightly different config than rc6. In rc6 I had enabled more debugging options and also the kdbg. Looking at the kernel messages when it stopped booting I saw that the last outputs always came from kdbg.
Then I disabled kdbg and the additional debugging options in the current master. Now the issue seems to be gone. I've bootet the kernel several times without any problems.
Comment 6 Martin Bammer 2009-05-29 18:44:04 UTC
Btw. I compiled rc5 with the same options as rc6 and rc7 and it showed the same issues.
Comment 7 Rafael J. Wysocki 2009-05-30 21:45:21 UTC
Notify-Also : Eric Anholt <eric@anholt.net>
Comment 8 Jesse Barnes 2009-06-01 10:51:39 UTC
Sounds like a kgdb issue then...
Comment 9 Rafael J. Wysocki 2009-06-07 21:09:41 UTC
On Sunday 07 June 2009, Martin Bammer wrote:
> Since i disabled most of the debug options this problem has gone. IMHO
> this issue has been caused by kdbg.
Comment 10 Rafael J. Wysocki 2009-06-07 21:10:59 UTC
Dropping from the list of recent regressions as per comments #8 and #9.
Comment 11 Gordon Jin 2009-09-17 03:24:52 UTC
So can we close this one?
Comment 12 Martin Bammer 2009-09-18 19:02:17 UTC
Yes this bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.