Bug 13377 - Microphone no longer works on Toshiba Satellite A100
Summary: Microphone no longer works on Toshiba Satellite A100
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Takashi Iwai
URL:
Keywords:
Depends on:
Blocks: 13070
  Show dependency tree
 
Reported: 2009-05-24 21:37 UTC by Rafael J. Wysocki
Modified: 2009-06-01 20:36 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30-rc6
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-05-24 21:37:15 UTC
Subject    : [Bisected regression] Microphone no longer works on Toshiba Satellite A100
Submitter  : "M. Vefa Bicakci" <bicave@superonline.com>
Date       : 2009-05-24 15:49
References : http://marc.info/?l=linux-kernel&m=124318383910011&w=4

Caused by:

commit 23f0c048ba59ad5c2f3fd85ed98360b631dbf6f8
Author: Takashi Iwai <tiwai@suse.de>
Date:   Thu Feb 26 13:03:58 2009 +0100

    ALSA: hda - Clean up the input pin setup in automatic mode

First-Bad-Commit : 23f0c048ba59ad5c2f3fd85ed98360b631dbf6f8

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-06-01 20:36:11 UTC
On Sunday 31 May 2009, M. Vefa Bicakci wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.29.  Please verify if it still should be listed and let me know
> > (either way).
> 
> Hello,
> 
> I am sorry for responding to your e-mail late. Takashi Iwai identified
> the cause of this problem and provided a patch. I tested the patch and
> confirmed that it solves the problem. The patch was integrated into
> mainline with the following commit:
> 
> === 8< ===
> commit 461c6c3a0a23a8fac1a4b636e93ff5dfe599a241
> Author: Takashi Iwai <tiwai@suse.de>
> Date:   Mon May 25 08:06:02 2009 +0200
> 
>     ALSA: hda - Add missing check of pin vref 50 and others in Realtek codecs
>     
>     Some Realtek codecs like ALC861 seem to support only VREF50 while the
>     current driver assumes it's only VREF80.  Check other VREF bits to set
>     the correct value.
>     
>     Signed-off-by: Takashi Iwai <tiwai@suse.de>

Note You need to log in before you can comment on or make changes to this bug.