Bug 13371 - s2disk hangs with e100, kernel 2.6.29 and later
s2disk hangs with e100, kernel 2.6.29 and later
Status: CLOSED DUPLICATE of bug 13353
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-05-24 20:29 UTC by Rafael J. Wysocki
Modified: 2011-03-03 01:10 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-05-24 20:29:37 UTC
Subject    : s2disk hangs with kernel >=2.6.29, SATA, Gigabyte EG45M-DS2H (bisected)
Submitter  : Richard Atterer <richard@2009.atterer.net>
Date       : 2009-05-16 22:51
References : http://marc.info/?l=linux-kernel&m=124251446428166&w=4
Handled-By : Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>

Caused by:

commit 295f00042aaf6b553b5f37348f89bab463d4a469
Author: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Date:   Fri Jan 2 16:12:48 2009 +0100

    ide: don't execute the next queued command from the hard-IRQ context (v2)

First-Bad-Commit : 295f00042aaf6b553b5f37348f89bab463d4a469

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Bartlomiej Zolnierkiewicz 2009-05-24 20:38:20 UTC
Please move this out from IDE:

It turned out later that issue also happens with *CONFIG_IDE=n* (the problem was bisected to commit 295f00042aaf6b553b5f37348f89bab463d4a469 which was quite soon fixed by commit 2ea5521022ac8f4f528dcbae02668e02a3501a5a).

I was working with Richard on bisecting it further during past week but since we are hitting a whole ton of unrelated kernel problems it takes a lot of time...
Comment 2 Rafael J. Wysocki 2009-05-25 23:05:44 UTC
First-Bad-Commit : Unknown
Not-Handled-By : Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Notify-Also : Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Comment 3 Rafael J. Wysocki 2009-05-25 23:13:15 UTC
References : http://lkml.org/lkml/2009/5/25/253
Comment 4 Rafael J. Wysocki 2009-06-01 20:16:38 UTC
On Sunday 31 May 2009, Richard Atterer wrote:
> This bug is still present.
> 
> On Sat, May 30, 2009 at 09:55:39PM +0200, Rafael J. Wysocki wrote:
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13371
> > Subject		: s2disk hangs with kernel 2.6.29 and later, SATA, Gigabyte EG45M-DS2H
> 
> Better: s2disk hangs with e100, kernel 2.6.29 and later
> 
> > Submitter	: Richard Atterer <richard@2009.atterer.net>
> > Date		: 2009-05-16 22:51 (15 days old)
> > References	: http://marc.info/?l=linux-kernel&m=124251446428166&w=4
> > 		  http://lkml.org/lkml/2009/5/25/253
> 
> Latest information: The e100 driver is responsible for the problem. 
> http://lkml.org/lkml/2009/5/25/440
 
Handled-By : Jeffrey Kirsher <jeffrey.t.kirsher@intel.com>
Not-Handled-By : Rafael J. Wysocki <rjw@sisk.pl>
Comment 5 Rafael J. Wysocki 2009-06-07 20:55:31 UTC
On Sunday 07 June 2009, you wrote:
> On Sun, Jun 07, 2009 at 12:06:23PM +0200, Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions 
> > introduced between 2.6.28 and 2.6.29.  Please verify if it still should 
> > be listed and let me know (either way).
> 
> Well, nobody has approached me with a patch to try out, so I think it's 
> still there. I've worked around the problem by blacklisting e100 to get it 
> rmmod'ed before the suspend.
Comment 6 ykzhao 2009-07-21 09:12:27 UTC
*** Bug 13353 has been marked as a duplicate of this bug. ***
Comment 7 Rafael J. Wysocki 2009-09-22 20:18:56 UTC

*** This bug has been marked as a duplicate of bug 13353 ***

Note You need to log in before you can comment on or make changes to this bug.