Bug 13364 - BUG: unable to handle kernel paging request at 429a4c40
BUG: unable to handle kernel paging request at 429a4c40
Status: CLOSED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 17:59 UTC by uzytkownik2@gmail.com
Modified: 2012-06-07 11:00 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: No


Attachments

Description uzytkownik2@gmail.com 2009-05-22 17:59:48 UTC
[   30.168154] BUG: unable to handle kernel paging request at 429a4c40
[   30.168162] IP: [<f840d262>] radeon_write_agp_location+0x22/0xc0 [radeon]
[   30.168175] *pde = 00000000 
[   30.168180] Oops: 0002 [#1] 
[   30.168184] last sysfs file: /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq
[   30.168188] Modules linked in: af_packet snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss reiserfs ext2 radeon drm usbhid hid tun ioatdma dca loop p4_clockmod speedstep_lib cpufreq_powersave tp_smapi thinkpad_ec configs arc4 snd_atiixp snd_ac97_codec ecb ac97_bus ath5k snd_pcm ehci_hcd snd_timer mac80211 ohci_hcd snd usbcore tg3 soundcore yenta_socket snd_page_alloc cfg80211 rsrc_nonstatic psmouse ati_agp rtc_cmos pcmcia_core parport_pc libphy rtc_core agpgart thermal thinkpad_acpi rtc_lib sg parport processor battery ac button thermal_sys rfkill hwmon led_class sr_mod cdrom evdev nvram unix
[   30.168234] 
[   30.168238] Pid: 2191, comm: X Not tainted (2.6.29-tuxonice-gcc4.4 #2) 18436NG
[   30.168241] EIP: 0060:[<f840d262>] EFLAGS: 00213287 CPU: 0
[   30.168247] EIP is at radeon_write_agp_location+0x22/0xc0 [radeon]
[   30.168250] EAX: ef46dc00 EBX: f6953c00 ECX: f8260168 EDX: 00000001
[   30.168252] ESI: ffffffff EDI: 00000000 EBP: f6867e74 ESP: f6867e58
[   30.168255]  DS: 007b ES: 007b FS: 0000 GS: 0033 SS: 0068
[   30.168258] Process X (pid: 2191, ti=f6866000 task=f6b97250 task.ti=f6866000)
[   30.168261] Stack:
[   30.168262]  f840f5a7 f6953ed4 f5888000 00007ffc f6953c00 ffffffff f6953c00 f6867eb4
[   30.168268]  f84104d2 f8425354 00000001 f6867f38 00000000 0000603f f6e8042c f6810c40
[   30.168274]  f8e1c000 f6adf2c0 f6adf1c0 f6825000 f6825000 f6adf2c0 fffffff4 f6867ef8
[   30.168280] Call Trace:
[   30.168283]  [<f840f5a7>] ? radeon_set_pcigart+0x397/0x820 [radeon]
[   30.168291]  [<f84104d2>] ? radeon_cp_init+0x772/0xd50 [radeon]
[   30.168301]  [<f83c6ef8>] ? drm_ioctl+0xd8/0x2e0 [drm]
[   30.168326]  [<f840fd60>] ? radeon_cp_init+0x0/0xd50 [radeon]
[   30.168332]  [<f83c6e20>] ? drm_ioctl+0x0/0x2e0 [drm]
[   30.168344]  [<c018d928>] ? vfs_ioctl+0x68/0x70
[   30.168352]  [<c018de12>] ? do_vfs_ioctl+0x72/0x5b0
[   30.168357]  [<c018207e>] ? vfs_write+0xfe/0x140
[   30.168362]  [<f87b8e60>] ? reiserfs_file_write+0x0/0xb0 [reiserfs]
[   30.168378]  [<c018e389>] ? sys_ioctl+0x39/0x60
[   30.168381]  [<c0103285>] ? sysenter_do_call+0x12/0x25
[   30.168387] Code: c3 90 8d b4 26 00 00 00 00 55 89 e5 53 0f b7 88 1c 03 00 00 83 f9 14 74 58 8d 59 ee 83 fb 01 76 68 83 f9 14 77 13 8b 80 2c 03 00 <00> 8b 40 10 05 4c 01 00 00 89 10 5b 5d c3 8b 88 2c 03 00 00 8b 
[   30.168415] EIP: [<f840d262>] radeon_write_agp_location+0x22/0xc0 [radeon] SS:ESP 0068:f6867e58
[   30.168425] ---[ end trace 3c2025f8245875cb ]---
[   30.169695] [drm:drm_release] *ERROR* Device busy: 1

X is working but I found it in dmesg. I guess it should not be here ;)
I did not noticed it last time so possibly it is not reproducable. However as it wrote down "BUG" I decieded to post it here anyway. Test on 'clean' kernel will follow.
Comment 1 Alex Deucher 2009-05-27 14:38:39 UTC
What radeon card are you using?  Is PAT enabled?
Comment 2 uzytkownik2@gmail.com 2009-05-27 16:33:26 UTC
PAT is enabled. Card is Radeon XPress 200M RC410.
Comment 3 Alex Deucher 2009-05-27 18:06:10 UTC
Is this reproducible?  If so does booting with nopat help?  Also, what do you mean by 'clean' kernel?  Are you running with local changes?  Does this still happen with a vanilla kernel?
Comment 4 uzytkownik2@gmail.com 2009-05-28 20:08:38 UTC
(In reply to comment #3)
> Is this reproducible?

As far - no as written.

> If so does booting with nopat help?  Also, what do you
> mean by 'clean' kernel?  Are you running with local changes?

A Gentoo tuxonice patchset.

> Does this still
> happen with a vanilla kernel?

I tried several time. What I observed is that either I cannot switch to a console or it does not ocure. It striked me now that this might prevent the changing to console (which would mean that it is present also on mainline git + wireless-testing + tuxonice). I'll test it.
Comment 5 a1d23ab4 2009-07-11 08:10:07 UTC
I have the same problem, but X also starts at the second attempt. Sometimes starting X totally hangs the computer.

dmesg portion:

... radeon module is loaded by boot process:
[drm] Initialized drm 1.1.0 20060810
[drm] Initialized radeon 1.30.0 20080528 for 0000:01:05.0 on minor 0
... booting goes on. It finishes, I start X:
[drm] Setting GART location based on new memory map
BUG: unable to handle kernel paging request at 1b513c28
IP: [<f9271cdd>] radeon_set_pcigart+0x4d1/0x13d7 [radeon]
*pdpt = 000000002e171001 *pde = 0000000000000000 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/devices/pci0000:00/0000:00:01.0/0000:01:05.0/enable
Modules linked in: ipv6 af_packet snd_pcm_oss snd_mixer_oss radeon drm snd_hda_codec_si3054 snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_timer snd soundcore snd_page_alloc atiixp ftdi_sio usbserial loop uhci_hcd ati_agp agpgart radeonfb fb_ddc i2c_algo_bit i2c_core 8139too mii kqemu fuse thermal ac battery asus_laptop led_class tun usb_storage dm_mod usbhid ohci_hcd ehci_hcd usbcore ide_cd_mod sr_mod cdrom ata_piix ahci btrfs zlib_deflate libcrc32c crc32c libata jfs xfs exportfs ext3 jbd

Pid: 2331, comm: X Not tainted (2.6.31-rc2-default #1) X51RL               
EIP: 0060:[<f9271cdd>] EFLAGS: 00013246 CPU: 0
EIP is at radeon_set_pcigart+0x4d1/0x13d7 [radeon]
EAX: 00000000 EBX: ec972c00 ECX: ec972c00 EDX: 000000ff
ESI: 00000001 EDI: 00000000 EBP: ec972800 ESP: ec137e60
 DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process X (pid: 2331, ti=ec136000 task=ec932830 task.ti=ec136000)
Stack:
 f92e0b08 ec972c00 00000000 f9273f21 f9201393 f6dcbb40 00000000 ec137e98
<0> 00000040 40546440 f6dcbb40 f91f4648 ec972800 f92733f8 00000004 00000898
<0> 00000001 40000000 02000000 00100000 000186a0 00000020 00000000 00003000
Call Trace:
 [<f9273f21>] ? radeon_cp_init+0xb29/0xb7c [radeon]
 [<f91f4648>] ? drm_ioctl+0x1c3/0x242 [drm]
 [<f92733f8>] ? radeon_cp_init+0x0/0xb7c [radeon]
 [<c01a723d>] ? vfs_ioctl+0x49/0x5f
 [<c01a77a4>] ? do_vfs_ioctl+0x4aa/0x4e5
 [<c019d190>] ? vfs_write+0xf4/0x105
 [<c01a7820>] ? sys_ioctl+0x41/0x58
 [<c0107714>] ? sysenter_do_call+0x12/0x28
Code: 03 00 00 b2 ff 8b 40 14 05 68 01 00 00 89 10 ba 2e 00 00 00 89 d8 e8 aa e4 ff ff a8 01 74 0c b8 c7 10 00 00 e8 4e 56 fc c6 eb e4 <8b> 83 28 10 ba 2e 00 00 00 89 d8 e8 aa e4 ff ff a8 01 74 0c b8 
EIP: [<f9271cdd>] radeon_set_pcigart+0x4d1/0x13d7 [radeon] SS:ESP 0068:ec137e60
CR2: 000000001b513c28
---[ end trace 9ce0b9a02936fcbc ]---
[drm:drm_release] *ERROR* Device busy: 1

Screen goes blank. FB console is not accessible.

Afterwards, I relaunch X (screen was off):

SysRq : Keyboard mode set to system default
[drm] Setting GART location based on new memory map
[drm] Loading R300 Microcode
[drm] Num pipes: 3
[drm] writeback test succeeded in 1 usecs
... some networking events ...
[drm] Num pipes: 3
mtrr: no MTRR for 90000000,8000000 found
[drm] Setting GART location based on new memory map
[drm] Loading R300 Microcode
[drm] Num pipes: 3
[drm] writeback test succeeded in 1 usecs

Now I see X session (still no switching to FB console, and send you the BUG output.

uname -a:
Linux 401a0bf1.ignorelist.com 2.6.31-rc2-default #1 SMP Mon Jul 6 19:44:22 UTC 2009 i686 GNU/Linux

Patches: No externals. Vanilla 2.6.28 tarball + 2.6.29 patch + 2.6.30 patch + 2.6.31-rc2 patch. Compiled with some random personal configuration.

video card:
ATI Technologies Inc RC410 [Radeon Xpress 200M] (1002:5a62)

Reproducibility: close to 100% while doing nothing special. Sometimes system hangs, so it would require finding HW to get dmesg in these cases. 

# CONFIG_X86_PAT is not set
Comment 6 a1d23ab4 2009-07-30 18:55:53 UTC
It's me again - testing with 2.6.31-rc4.

I have FB console (fbterm works OK) and launched X (DRI is enabled). No blank screens, switches are OK, no paging request complains. Looks like the fixes helped. 

Thanks a lot.
Comment 7 a1d23ab4 2009-07-31 04:56:56 UTC
Behavior became less reproducible after I added some modules (notably acpi video.ko). Although I have less upleasant effects than earlier. 

I get blank screen, but when I relaunch X FB console goes back up, too.

[  259.477785] BUG: unable to handle kernel paging request at 838b00fa
[  259.477798] IP: [<fa817681>] radeon_set_pcigart+0x5f6/0x2764 [radeon]
[  259.477817] *pdpt = 000000002cca6001 *pde = 0000000000000000 
[  259.477823] Oops: 0000 [#1] SMP 
[  259.477827] last sysfs file: /sys/devices/pci0000:00/0000:00:01.0/0000:01:05.0/enable
[  259.477834] Modules linked in: usblp raid456 raid6_pq async_xor async_memcpy async_tx xor raid1 raid0 md_mod snd_pcm_oss sn
d_mixer_oss af_packet video output ipv6 ipip tunnel4 radeon drm snd_hda_codec_si3054 snd_hda_codec_realtek snd_hda_intel snd_h
da_codec snd_hwdep snd_pcm snd_timer snd soundcore snd_page_alloc ftdi_sio usbserial loop ati_agp agpgart p4_clockmod speedste
p_lib 8139too mii kqemu fuse thermal thermal_sys hwmon ac battery tun usb_storage usb_libusual dm_mod ide_generic ide_gd_mod p
ata_marvell ata_piix sata_uli sata_sis pata_sis sata_via sata_nv xtkbd atkbd ohci_hcd ssb pcmcia pcmcia_core firmware_class eh
ci_hcd uhci_hcd usbhid hid usbcore unix btrfs zlib_deflate libcrc32c crc32c sd_mod crc_t10dif jfs nls_base xfs exportfs ext3 j
bd mbcache synaptics_i2c sermouse psmouse libps2 pcips2 i8042 serio evdev mousedev ide_cd_mod ide_core pktcdvd ahci sr_mod cdr
om pata_atiixp libata scsi_mod radeonfb fb_ddc backlight i2c_algve o_bit cfbcopyarea i2c_core cfbimgblt cfbfillrect fbcon fbdev tileblit font bitblit fbcon_rotate fbcon_cw fbcon_ud fbcon_ccw softcursor fb
[  259.477961] 
[  259.477966] Pid: 5072, comm: X Not tainted (2.6.31-rc4 #1) X51RL               
[  259.477970] EIP: 0060:[<fa817681>] EFLAGS: 00013246 CPU: 0
[  259.477981] EIP is at radeon_set_pcigart+0x5f6/0x2764 [radeon]
[  259.477985] EAX: fa8a016e EBX: ea5c3000 ECX: 2ed68000 EDX: 44000039
[  259.477989] ESI: 00000001 EDI: 00000000 EBP: ec481e58 ESP: ec481e48
[  259.477992]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[  259.477997] Process X (pid: 5072, ti=ec481000 task=f19c49e0 task.ti=ec481000)
[  259.478000] Stack:
[  259.478002]  66000001 00000000 ea5c3000 00000000 ec481e78 fa81ba30 ec481e70 ec8c0c60
[  259.478011] <0> ea5c2c00 fa86f96c ec481e8c 40546440 ec481f18 fa762ae0 ec8c0c60 ea5c2c00
[  259.478020] <0> fa81a80e 00000004 00000898 00000001 40000000 02000000 00100000 000186a0
[  259.478030] Call Trace:
[  259.478043]  [<fa81ba30>] ? radeon_cp_init+0x1222/0x15b0 [radeon]
[  259.478073]  [<fa762ae0>] ? drm_ioctl+0x38a/0x492 [drm]
[  259.478086]  [<fa81a80e>] ? radeon_cp_init+0x0/0x15b0 [radeon]
[  259.478111]  [<c118e013>] ? vfs_ioctl+0xc6/0xf4
[  259.478117]  [<c118eab1>] ? do_vfs_ioctl+0x907/0x933
[  259.478124]  [<c1176cc7>] ? fsnotify_modify+0xa2/0xbb
[  259.478129]  [<c117704c>] ? do_sync_write+0x0/0x13d
[  259.478135]  [<c1178211>] ? vfs_write+0x14a/0x17e
[  259.478140]  [<c118eb6a>] ? sys_ioctl+0x8d/0xdf
[  259.478146]  [<c1005543>] ? sysenter_do_call+0x12/0x28
[  259.478149] Code: 15 3c 13 87 fa 00 ba 39 00 00 8b 40 14 05 68 01 00 00 66 ba ff 00 89 10 83 05 38 13 87 fa 01 83 15 3c 13 87 fa 00 ba 39 00 00 44 <13> 87 fa 00 8b 83 3c 03 00 00 8b 40 14 83 c0 78 ba 39 02 00 00 
[  259.478199] EIP: [<fa817681>] radeon_set_pcigart+0x5f6/0x2764 [radeon] SS:ESP 0068:ec481e48
[  259.478212] CR2: 00000000838b00fa
[  259.478217] ---[ end trace 8d09e68c39e6286a ]---

Note You need to log in before you can comment on or make changes to this bug.