Bug 13363 - touchpad button won't work after switching off once
Summary: touchpad button won't work after switching off once
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Dmitry Torokhov
Depends on:
Reported: 2009-05-22 13:33 UTC by Benjamin
Modified: 2015-02-19 15:29 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.28-11-generic #42-Ubuntu SMP
Regression: No
Bisected commit-id:

Add Aspire 4810T to the nomux list (840 bytes, patch)
2013-02-18 04:16 UTC, Dmitry Torokhov
Details | Diff

Description Benjamin 2009-05-22 13:33:17 UTC
On the acer aspire 5738, there is a new button next to the touchpad. If you
press it, the touchpad is switched off, and the button's LED is switched on (LED on = locked).
After that, you cannot switch the touchpad on again.

if you reload the module psmouse, you can switch it on again. After switching it off, you cannot switch it on, just as before.

Invalid bug at FDO (who said it is a kernel bug):

Original bug on launchpad:

Please take a look at the bug filed at FDO. Most information can be found there.
Comment 1 Dmitry Torokhov 2009-09-05 05:29:09 UTC
Should be fixed by the following commit: ced909ff048c9950e211783417f3c01361f3be28

On older kernels the problem can be worked around with i8042.nomux option.
Comment 2 Benjamin 2010-05-08 23:16:06 UTC

I tried to verify your change, but it doesn't work with either the i8042.nomux-Option, nor does it work with Ubuntu Lucid (which should contain the patch you mentioned).

Can you please take another look at this problem?

Here are some links where other users wrote about this bug.

Thanks & regards,
Comment 3 Maximiliano Castañón 2010-09-20 21:26:56 UTC
on Fedora 12 with Kernel 

[root@gateway maximi89]# uname -a
Linux gateway #1 SMP Fri Aug 27 06:33:34 UTC 2010 i686 athlon i386 GNU/Linux

Works very good with option "i8042.nomux=1"

But there is something what it's not ok, if you leave a finger on the touchpad and with the other hand you activate the touchpad, the touchpad doesn't activate... why happens this?
removing the hand from touchpad it activate normally.
Comment 4 Alan 2012-10-30 17:31:55 UTC
If this is still seen on modern kernels then please re-open/update
Comment 5 Adam Niedling 2012-12-09 15:03:21 UTC
I still have this issue with kernel 3.7 rc8 and an Acer 4810TG laptop if I remove the i8042.nomux option.

Further information at the downstream bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/811466
LSPCI: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/811466/+attachment/2211441/+files/Lspci.txt
Comment 6 Adam Niedling 2013-02-17 10:50:44 UTC
Can you reopen this bug since this is still an issue as I've indicated in my previous comment?
Comment 7 Dmitry Torokhov 2013-02-18 04:16:14 UTC
Created attachment 93481 [details]
Add Aspire 4810T to the nomux list

Adam, does this patch fixes the issue for you? Thanks!
Comment 8 Adam Niedling 2013-08-10 11:11:47 UTC
Has that patch make its way to an official release or do I have to compile it myself somehow?
Comment 9 Alan 2013-12-10 16:32:47 UTC
At this point it seems not, presumably because Dmitry never got confirmation. So yes apply, test report

Note You need to log in before you can comment on or make changes to this bug.