Bug 13329 - cifs_close: NULL pointer dereference
cifs_close: NULL pointer dereference
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: CIFS
All Linux
: P1 normal
Assigned To: fs_cifs
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-05-16 21:37 UTC by Rafael J. Wysocki
Modified: 2009-05-23 00:01 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30-rc6
Tree: Mainline
Regression: Yes


Attachments
patch -- revert lookup open intent patches (13.65 KB, patch)
2009-05-17 02:35 UTC, Jeff Layton
Details | Diff

Description Rafael J. Wysocki 2009-05-16 21:37:57 UTC
Subject    : [2.6.30-rc6] cifs_close: NULL pointer dereference
Submitter  : Luca Tettamanti <kronos.it@gmail.com>
Date       : 2009-05-16 16:28
References : http://marc.info/?l=linux-kernel&m=124249133701702&w=4

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Jeff Layton 2009-05-17 02:33:01 UTC
I've been able to reproduce this too.

The problem seems to be with the open lookup intent patches that went in not too long ago. Reverting those fixes the problem for me.
Comment 2 Jeff Layton 2009-05-17 02:35:41 UTC
Created attachment 21378 [details]
patch -- revert lookup open intent patches

This patch fixes the problem for me. At this point, I think it would probably be best to pull those patches until they can be better tested.
Comment 3 Steve French 2009-05-17 03:20:16 UTC
Note that reverting the posix open code would mean that we no longer will use the preferred open call (when it is available, e.g. when the server is Samba) in a key path - and thus not get full posix semantics (to Samba) on byte range locks and write.

Since I haven't heard from the patch author (Shirish) today, I will take a look and see if it is simple to fix.
Comment 4 Jeff Layton 2009-05-17 10:07:07 UTC
I'm not suggesting that we pull the posix open code, just the newer code that makes opens happen during lookup.
Comment 5 Rafael J. Wysocki 2009-05-23 00:01:04 UTC
Fixed by commit 703a3b8e5c01cf6fb33c6d8dc99905f889a4e992 .

Note You need to log in before you can comment on or make changes to this bug.