Bug 13327 - Regression: 2.6.30-rc5 and rt2x00 / rt2500pci
Regression: 2.6.30-rc5 and rt2x00 / rt2500pci
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: John W. Linville
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-05-16 21:30 UTC by Rafael J. Wysocki
Modified: 2009-05-18 16:35 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-05-16 21:30:40 UTC
Subject    : Regression: 2.6.30-rc5 and rt2x00 / rt2500pci
Submitter  : Ken Lewis <kennylewis@gmail.com>
Date       : 2009-05-15 14:40
References : http://marc.info/?l=linux-kernel&m=124239988223614&w=4
Handled-By : "John W. Linville" <linville@tuxdriver.com>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Ken Lewis 2009-05-17 15:44:52 UTC
John Linville has provided a patch at http://www.kernel.org/pub/linux/kernel/people/linville/wireless-2.6/0002-mac80211-avoid-NULL-ptr-deref-when-finding-max_rate.patch

This patch appears to resolve the issue and John's reporting e-mail says that it received a pull request to Dave M and should be usptream with Linus shortly.
Comment 2 John W. Linville 2009-05-18 12:19:01 UTC
commit 621ad7c96aa138cfeab53cd4debc5a4e08b2189b
Author: John W. Linville <linville@tuxdriver.com>
Date:   Tue May 5 15:18:26 2009 -0400

    mac80211: avoid NULL ptr deref when finding max_rates in PID and minstrel
    
    "There is another problem with this piece of code. The sband will be NULL
    after second iteration on single band device and cause null pointer
    dereference. Everything is working with dual band card. Sorry, but i
    don't know how to explain this clearly in English. I have looked on the
    second patch for pid algorithm and found similar bug."
    
    Reported-by: Karol Szuster <qflon@o2.pl>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>

Note You need to log in before you can comment on or make changes to this bug.