Bug 13318 - AGP doesn't work anymore on nforce2
AGP doesn't work anymore on nforce2
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(AGP)
All Linux
: P1 normal
Assigned To: Dave Airlie
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-05-15 22:17 UTC by Rafael J. Wysocki
Modified: 2009-09-10 22:46 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29.2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-05-15 22:17:44 UTC
Subject    : PROBLEM: 2.6.29.2 - AGP doesn't work anymore on my nforce2
Submitter  : Karsten Mehrhoff <kawime@gmx.de>
Date       : 2009-04-30 8:51
References : http://marc.info/?l=linux-kernel&m=124108156417560&w=4
Handled-By : Shaohua Li <shaohua.li@intel.com>
Notify-Also : Jerome Glisse <glisse@freedesktop.org>
Notify-Also : Michel Dänzer <michel@daenzer.net>

Caused by:

commit 59de2bebabc5027f93df999d59cc65df591c3e6e
Author: Shaohua Li <shaohua.li@intel.com>
Date:   Mon Apr 20 10:08:35 2009 +1000

    agp: zero pages before sending to userspace

    AGP pages might be mapped into userspace finally, so the pages should be
    set to zero before userspace can use it. Otherwise there is potential
    information leakage.

    Signed-off-by: Shaohua Li <shaohua.li@intel.com>
    Signed-off-by: Dave Airlie <airlied@redhat.com>

First-Bad-Commit : 59de2bebabc5027f93df999d59cc65df591c3e6e

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-09-10 20:44:49 UTC
Confirmed to be fixed in 2.6.31, closing.
Comment 2 Rafael J. Wysocki 2009-09-10 22:46:05 UTC
On Thursday 10 September 2009, Karsten Mehrhoff wrote:
> Hi all,
> 
> Today i compilied the new kernel 2.6.31 and everything works ok.
> Maybe it's related to other changes in the generic.c file.
> 
> So everything works ok for me with AGP in 2.6.31.
> I do not get the problem like it was in 2.6.30.x
> 
> 
> 2.6.31:
> =======
> $ dmesg | grep agp
> [    0.668878] Linux agpgart interface v0.103
> [    0.669457] agpgart: Detected NVIDIA nForce2 chipset
> [    0.674984] agpgart-nvidia 0000:00:00.0: AGP aperture is 64M @  
> 0xe0000000
> [   35.184416] agpgart-nvidia 0000:00:00.0: AGP 3.0 bridge
> [   35.184437] agpgart-nvidia 0000:00:00.0: putting AGP V3 device into 8x  
> mode
> 
> 
> $ dmesg | grep drm
> [    0.675940] [drm] Initialized drm 1.1.0 20060810
> [    0.678840] [drm] Initialized radeon 1.31.0 20080528 for 0000:02:00.0  
> on minor 0
> [   35.460115] [drm] Setting GART location based on new memory map
> [   35.460125] [drm] Loading R300 Microcode
> [   35.460170] [drm] Num pipes: 1
> [   35.460178] [drm] writeback test succeeded in 1 usecs
> 
> 
> -Karsten-
> 
> 
> [Am 06.09.2009, 20:11 Uhr, schrieb Rafael J. Wysocki <rjw@sisk.pl>]
> 
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.29 and 2.6.30.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.29 and 2.6.30.  Please verify if it still should
> > be listed and let me know (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13318
> > Subject		: AGP doesn't work anymore on nforce2
> > Submitter	: Karsten Mehrhoff <kawime@gmx.de>
> > Date		: 2009-04-30 8:51 (130 days old)

Note You need to log in before you can comment on or make changes to this bug.