Bug 13309 - Kernel PANIC
Kernel PANIC
Status: CLOSED UNREPRODUCIBLE
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-05-14 13:59 UTC by biohazrd
Modified: 2009-08-21 14:23 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.30-r5
Tree: Mainline
Regression: Yes


Attachments
kernel config options (60.68 KB, application/x-gzip)
2009-05-14 13:59 UTC, biohazrd
Details
2.6.30-r5 kernel config (2 bytes, text/plain)
2009-08-21 14:23 UTC, Phillip Merensky
Details

Description biohazrd 2009-05-14 13:59:55 UTC
Created attachment 21356 [details]
kernel config options

I am not sure what changed bewtween 2.6.29 and 2.6.30, but using the exact same .config file to compile I get a kernel panic.

PANIC: early exception 0e rip 10:ffffffff810a029b error 0 cr2 21810

This is the first time I have reported a kernel problem, so I am not sure what more information I need to provide.  Please let me know and I will be happy to add more information.  

If I need to configure some debug options that will give more output when I boot, let me know what those are as well. If I understand correctly it appears to be a page fault error?

Not sure if it would be useful, but below are some details about my installed libs.

Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.29-gentoo-r3-x86_64-Intel-R-_Xeon-R-_CPU_E5520_@_2.27GHz-with-gentoo-2.0.0
Timestamp of tree: Wed, 13 May 2009 04:00:03 +0000
app-shells/bash:     4.0_p17-r1
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3, 2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 x86 ~amd64 ~x86"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -msse4 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/hosts /etc/init.d /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -msse4 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://mirror.usu.edu/mirrors/gentoo/ "
LDFLAGS="-Wl,-O1"
LINGUAS="en_US"
MAKEOPTS="-j24"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility ace acl acpi alsa amd64 apache2 automount berkdb binary-drivers bittorrent bluetooth branding bzip2 cairo cdda cddb cdparanoia cdr cdrom cli consolekit cracklib crypt cups curl custom-optimization dbus dhcp divx dri dv dvd dvdr dvdread dvi eds encode epiphany esd evo fbsplash ffmpeg firefox flac foomaticdb fortran ftp gdbm gdm gedit gimp gimpprint gkrellm glitz gmedia gnome gnome-print gpm gs gstreamer gtk gtkhtml hal iconv id3tag ieee1394 ipod ipv6 isdnlog java javascript jpeg jpeg2k lame libsexy live lm_sensors mad midi mmx mmxext motif moznoirc moznomail mp3 mp4 mp4live mpeg mpeg2 mplayer mudflap multilib multislot multitarget musicbrainz mysql nautilus ncurses networkmanager new-interface nfs nls nptl nptlonly nsplugin nvidia ogg openal openexr opengl openmp opensslcrypt pam pango pcre pdf perl php player png podcast pppd python quicktime readline realmedia reflection rhythmbox samba sdl session shaper sockets sound sox spell spl sqlite sse sse2 ssl ssse3 subversion swat sysfs tagwriting tcl tcpd theora tiff tivo tk truetype unicode usb verse vorbis wmp x264 xine xorg xscreensaver xulrunner xv xvid yv12 zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andrew Morton 2009-05-14 15:03:38 UTC
> PANIC: early exception 0e rip 10:ffffffff810a029b error 0 cr2 21810

Is that the only info it gave you?  No stack backtrace?
Comment 2 biohazrd 2009-05-14 23:18:41 UTC
Ok, now this is really strange.  I rebooted to check for additional output, which I don't recall; but it booted fine this time.  I am tending to lean toward a memory problem as the only thing I did different was swap the DIMM's to another slot and turn on ECC scrubbing and patrol.

Odd it failed like 5 times and the other kernel would boot up fine, but after switching memory around it booted up without a problem.

You can probably close this bug.  Thank you for the quick response.

Even more so... Andrew thank you for you involvement with Linux in general!
Comment 3 Phillip Merensky 2009-08-21 14:18:04 UTC
Hello.
I got the same error on one of our servers (PANIC: early exception 0e rip 10:ffffffff810a029b error 0 cr2 21810) and also did not get a stacktrace. Even after recompiling the kernel and rebooting it does not work. However I did not try to reboot after it hung the first time. Tested kernel was 2.6.30-r5. 

emerge --info is:
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r5 x86_64)
=================================================================                                        
System uname: Linux-2.6.29-gentoo-r5-x86_64-AMD_Opteron-tm-_Processor_248-with-glibc2.2.5                
Timestamp of tree: Fri, 21 Aug 2009 08:15:01 +0000                                                       
app-shells/bash:     3.2_p39                                                                             
dev-java/java-config: 2.1.8-r1                                                                           
dev-lang/python:     2.4.4-r13, 2.5.4-r3                                                                 
sys-apps/baselayout: 1.12.11.1                                                                           
sys-apps/sandbox:    1.6-r2                                                                              
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon64"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/tomcat-6/webapps/ROOT"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=athlon64"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl amd64 apache2 authdaemond bacula-console bash-completion berkdb bzip2 caps cli cracklib crypt cups dri fortran ftp gd gdbm gpm iconv ipv6 isdnlog java jpeg jpeg2k json logrotate logwatch maildir mmx mng mpeg mudflap multilib munin-apache mysql mysqli ncurses nls nptl nptlonly openmp pam pcre perl png pop pppd python qmail readline reflection session snmp spl sse sse2 ssl svg sysfs tcpd threads threadsafe truetype unicode ups userlocales vhosts vim vim-syntax xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav deflate dir env expires filter headers include info log_config logio mime negotiation proxy proxy_connect proxy_ftp proxy_http rewrite setenvif speling status unique_id usertrack vhost_alias cern_meta charset_lite dav_fs dav_lock dbd disk_cache dumpio ext_filter file_cache ident imagemap mem_cache mime_magic proxy_ajp proxy_balancer substitute userdir version" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

If you need additional info me know. 

Testing new patches is not that easy because the server is a headless machine without remote management card and restricted physical access.

Thanks in advance
Phillip
Comment 4 Phillip Merensky 2009-08-21 14:23:17 UTC
Created attachment 22799 [details]
2.6.30-r5 kernel config

The kernel config was created using 'make oldconfig' from a 2.6.29-gentoo-r5-kernel

Note You need to log in before you can comment on or make changes to this bug.