Bug 13301 - wrong mutex lock in lookup_one_len
wrong mutex lock in lookup_one_len
Status: CLOSED DUPLICATE of bug 13151
Product: File System
Classification: Unclassified
Component: ReiserFS
All Linux
: P1 normal
Assigned To: ReiseFS developers team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 17:22 UTC by Martin Bammer
Modified: 2009-05-16 21:05 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30-rc5
Tree: Mainline
Regression: No


Attachments
dmesg output (60.26 KB, text/plain)
2009-05-13 17:22 UTC, Martin Bammer
Details
dmidecode output (9.71 KB, text/plain)
2009-05-13 17:24 UTC, Martin Bammer
Details
lspci -v output (5.84 KB, text/plain)
2009-05-13 17:32 UTC, Martin Bammer
Details
kernel configuration (85.51 KB, text/plain)
2009-05-13 17:35 UTC, Martin Bammer
Details

Description Martin Bammer 2009-05-13 17:22:49 UTC
Created attachment 21328 [details]
dmesg output

When kernel 2.6.30-rc5 boots I get the following output:
...
[    6.525098] REISERFS (device sda1): found reiserfs format "3.6" with standard journal
[    6.525309] REISERFS (device sda1): using ordered data mode
[    6.550458] REISERFS (device sda1): journal params: device sda1, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
[    6.551234] REISERFS (device sda1): checking transaction log (sda1)
[    6.601514] REISERFS (device sda1): Using r5 hash to sort names
[    6.601546] ------------[ cut here ]------------
[    6.601561] WARNING: at fs/namei.c:1251 warn_slowpath_null+0x10/0x15()
[    6.601573] Hardware name: PC-81005
[    6.601583] Modules linked in:
[    6.601603] Pid: 1515, comm: exe Not tainted 2.6.30-rc5 #2
[    6.601615] Call Trace:
[    6.601638]  [<c012e9a2>] warn_slowpath_fmt+0x72/0xa1
[    6.601663]  [<c0290035>] ? end_that_request_last+0xd/0x1f0
[    6.601685]  [<c0143c1d>] ? up+0xc/0x2f
[    6.601706]  [<c02a328f>] ? _raw_spin_trylock+0xf/0x30
[    6.601727]  [<c02a355e>] ? _raw_spin_unlock+0x78/0x7e
[    6.601748]  [<c02a355e>] ? _raw_spin_unlock+0x78/0x7e
[    6.601779]  [<c014c262>] ? trace_hardirqs_off+0xb/0xd
[    6.601792]  [<c04c38f9>] ? _spin_unlock_irqrestore+0x5f/0x6c
[    6.601803]  [<c012ef1c>] ? release_console_sem+0x1a1/0x1ce
[    6.601814]  [<c012f41e>] ? vprintk+0x2e8/0x31d
[    6.601826]  [<c0140020>] ? kthread_stop+0x44/0xf5
[    6.601836]  [<c014c37b>] ? lock_release_holdtime+0xb6/0xbb
[    6.601847]  [<c01b3aaf>] ? d_instantiate+0x32/0x3f
[    6.601857]  [<c012e9e1>] warn_slowpath_null+0x10/0x15
[    6.601869]  [<c01ae81a>] lookup_one_len+0x33/0x9d
[    6.601881]  [<c01f9a6d>] ? reiserfs_info+0x2c/0x47
[    6.601892]  [<c020638b>] reiserfs_xattr_init+0x30/0x83
[    6.601902]  [<c01f86eb>] reiserfs_fill_super+0xb4d/0xc85
[    6.601913]  [<c014bc4d>] ? graph_unlock+0x5d/0x69
[    6.601924]  [<c029ef3c>] ? string+0x33/0x81
[    6.601935]  [<c029f920>] ? vsnprintf+0x2cd/0x310
[    6.601946]  [<c0143c1d>] ? up+0xc/0x2f
[    6.601957]  [<c029f9c8>] ? snprintf+0x15/0x17
[    6.601968]  [<c01e1d1b>] ? disk_name+0x5a/0x67
[    6.601979]  [<c01a809a>] get_sb_bdev+0xf5/0x13b
[    6.601991]  [<c01f6075>] get_super_block+0x13/0x15
[    6.602001]  [<c01f7b9e>] ? reiserfs_fill_super+0x0/0xc85
[    6.602011]  [<c01a7d6a>] vfs_kern_mount+0x84/0xfd
[    6.602021]  [<c01a7e27>] do_kern_mount+0x32/0xba
[    6.602032]  [<c01b9aa3>] do_mount+0x62d/0x667
[    6.602042]  [<c02a328f>] ? _raw_spin_trylock+0xf/0x30
[    6.602052]  [<c01b9b43>] sys_mount+0x66/0x9f
[    6.602064]  [<c0102c35>] syscall_call+0x7/0xb
[    6.602072] ---[ end trace f247137751f6e628 ]---
[   10.104913] udev: starting version 141
[   11.581506] input: PC Speaker as /devices/platform/pcspkr/input/input7
...

This occurs at every boot. Further the dmesg contains a lot's of lines like that:
[  196.428278] REISERFS warning (device sda1): jdm-20004 reiserfs_delete_xattrs: Couldn't delete all xattrs (-13)
[  196.428286]
Comment 1 Martin Bammer 2009-05-13 17:24:42 UTC
Created attachment 21329 [details]
dmidecode output
Comment 2 Martin Bammer 2009-05-13 17:32:00 UTC
Created attachment 21330 [details]
lspci -v output
Comment 3 Martin Bammer 2009-05-13 17:35:16 UTC
Created attachment 21331 [details]
kernel configuration
Comment 4 Jeff Mahoney 2009-05-13 18:32:08 UTC
This is a duplicate of 13151, and was fixed with commit 5a6059c358d3b3004cb6b8562e3b049b1f8564f9. It's in -rc5-git1.
Comment 5 Stefan Richter 2009-05-16 20:59:13 UTC

*** This bug has been marked as a duplicate of bug 13151 ***

Note You need to log in before you can comment on or make changes to this bug.