Bug 13293 - Kernel BUG under network load with gianfar
Kernel BUG under network load with gianfar
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-05-13 09:43 UTC by Rafael J. Wysocki
Modified: 2009-05-30 21:33 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-05-13 09:43:15 UTC
Subject    : [BUG] 2.6.30-rc4: Kernel BUG under network load with gianfar
Submitter  : Michael Guntsche <mike@it-loops.com>
Date       : 2009-05-03 13:36
References : http://marc.info/?l=linux-kernel&m=124135824600924&w=4

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-05-13 09:45:01 UTC
Caused by:

commit 0fd56bb5be6455d0d42241e65aed057244665e5e
Author: Andy Fleming <afleming@freescale.com>
Date:   Wed Feb 4 16:43:16 2009 -0800

    gianfar: Add support for skb recycling

    Signed-off-by: Andy Fleming <afleming@freescale.com>
    Signed-off-by: David S. Miller <davem@davemloft.net>

First-Bad-Commit : 0fd56bb5be6455d0d42241e65aed057244665e5e
Comment 2 Rafael J. Wysocki 2009-05-20 20:53:43 UTC
On Wednesday 20 May 2009, Michael Guntsche wrote:
> 
> On May 16, 2009, at 21:20, Rafael J. Wysocki wrote:
> 
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.29.  Please verify if it still should be listed and let me  
> > know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13293
> > Subject		: Kernel BUG under network load with gianfar
> > Submitter	: Michael Guntsche <mike@it-loops.com>
> > Date		: 2009-05-03 13:36 (14 days old)
> >
> 
> This problem still happens with the latest HEAD from git. Reverting  
> the patch give me a rock stable system that can handle full laod for  
> several days without any problems at all.
Comment 3 Rafael J. Wysocki 2009-05-24 21:32:42 UTC
Handled-By : Lennert Buytenhek <buytenh@wantstofly.org>
Patch : http://patchwork.kernel.org/patch/25518/
Comment 4 Rafael J. Wysocki 2009-05-30 21:33:38 UTC
Fixed by commit 4e2fd555199977c5994d1a4d2d3b8761b20ca4c7 .

Note You need to log in before you can comment on or make changes to this bug.