Bug 13226 - [2.6.29 regression] Software suspend no longer works
[2.6.29 regression] Software suspend no longer works
Status: CLOSED INVALID
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 blocking
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-05-02 21:45 UTC by Artem S. Tashkinov
Modified: 2011-03-03 01:12 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.29.2 2.6.30
Tree: Mainline
Regression: Yes


Attachments
Miscellaneous /proc information, dmidecode/lspci/dmesg and kernel configs (45.10 KB, application/octet-stream)
2009-05-02 21:45 UTC, Artem S. Tashkinov
Details

Description Artem S. Tashkinov 2009-05-02 21:45:15 UTC
Created attachment 21192 [details]
Miscellaneous /proc information, dmidecode/lspci/dmesg and kernel configs

Last kernel known to work: 2.6.28.x
Failing kernels: 2.6.29, 2.6.30 (rc4 as for now)

Hardware configuration:
CPU: Athlon 64 X2 5200
MB: Gigabyte M61P-S3
RAM: 4GB
GPU: NVIDIA 8800GT (with or *without* proprietary drivers)
TV card: GotView PCI DVD Lite (with or *without* ivtv drivers loaded)
Arch: i386 [kernel compiled for amd-k8 cpu]

lspci:
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
01:08.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 10)
01:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
01:09.0 Generic system peripheral [0841]: Creative Labs SB Live! EMU10k1 (rev 07)
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
01:09.1 Input device controller: Creative Labs SB Live! Game Port (rev 07)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
01:07.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
02:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GT (rev a2)

Bug description:

Since kernel 2.6.29 software suspend no longer works. The computer suspends successfully but then I cannot wake it up - it powers on but the screen remains black, network interfaces are inaccessible, keyboard buttons are not working (leds cannot be changed by pressing Caps Lock/Scroll Lock/etc).
Comment 1 ykzhao 2009-07-20 14:44:45 UTC
From the description it seems that this is a regression.
Will you please use the git-bisect to identify the bad commit which causes the regression?
Will you please do the following test on the failing kernel?
    a. kill the process using /proc/acpi/event
    b. echo mem > /sys/power/state; dmesg >dmesg_after; sync; 
    c. press the power button and see whether the box can be resumed.
    d. If it can't be resumed, please reboot the system and see whether there exists the file of dmesg_after.
   
thanks.
Comment 2 Rafael J. Wysocki 2009-07-20 15:58:31 UTC
Also, is there any chance to try 2.6.31-rc3 (or later)?
Comment 3 Artem S. Tashkinov 2009-07-20 16:15:29 UTC
This bug description is wrong. I'm closing it to open a new one.

Note You need to log in before you can comment on or make changes to this bug.