Bug 13188 - horizontal strips of the screen frozen
horizontal strips of the screen frozen
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
: 13187 (view as bug list)
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-25 20:49 UTC by Rafael J. Wysocki
Modified: 2009-05-18 18:01 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-25 20:49:00 UTC
Subject    : [bisected regression] 2.6.30rc2 horizontal strips of the screen frozen
Submitter  : Justin Madru <jdm64@gawab.com>
Date       : 2009-04-24 20:59
References : http://marc.info/?l=linux-kernel&m=124060685315937&w=4

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 280b713b5b0fd84cf2469098aee88acbb5de859c
Author: Eric Anholt <eric@anholt.net>
Date:   Thu Mar 12 16:56:27 2009 -0700

drm/i915: Allow tiling of objects with bit 17 swizzling by the CPU.

First-Bad-Commit : 280b713b5b0fd84cf2469098aee88acbb5de859c
Comment 1 Rafael J. Wysocki 2009-04-26 12:12:02 UTC
*** Bug 13187 has been marked as a duplicate of this bug. ***
Comment 2 Rafael J. Wysocki 2009-05-18 17:58:29 UTC
On Monday 18 May 2009, Justin Madru wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.29.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13188
> > Subject		: horizontal strips of the screen frozen
> > Submitter	: Justin Madru <jdm64@gawab.com>
> > Date		: 2009-04-24 20:59 (23 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=280b713b5b0fd84cf2469098aee88acbb5de859c
> > References	: http://marc.info/?l=linux-kernel&m=124060685315937&w=4
> >
> >
> >
> >   
> As far as I can tell, this seams to be fixed by the intel-2.7.1 driver, 
> and the bug only happened with UXA.
> I did some minor testing and I couldn't trigger the bug. (earlier 
> discussion in http://lkml.org/lkml/2009/4/23/587)
> So this seams to be a user space bug, fixed in the intel-2.7.1 bug fix 
> release (intel-2.7.0 still has the issue).

Note You need to log in before you can comment on or make changes to this bug.