Bug 13185 - New x86 warning
Summary: New x86 warning
Status: CLOSED DOCUMENTED
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_i386
URL:
Keywords:
Depends on:
Blocks: 13070
  Show dependency tree
 
Reported: 2009-04-25 20:22 UTC by Rafael J. Wysocki
Modified: 2009-04-26 12:13 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-25 20:22:11 UTC
Subject    : New x86 warning
Submitter  : Jeff Garzik <jeff@garzik.org>
Date       : 2009-04-22 6:46
References : http://marc.info/?l=linux-kernel&m=124038280020950&w=4
Handled-By : Andi Kleen <andi@firstfloor.org>
Patch      : http://patchwork.kernel.org/patch/19330/
Patch      : http://patchwork.kernel.org/patch/19406/
Notify-Also : Ingo Molnar <mingo@elte.hu>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-04-26 12:10:58 UTC
On Sunday 26 April 2009, Ingo Molnar wrote:
> 
> * Rafael J. Wysocki <rjw@sisk.pl> wrote:
> 
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.29.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=13185
> > Subject             : New x86 warning
> > Submitter   : Jeff Garzik <jeff@garzik.org>
> > Date                : 2009-04-22 6:46 (4 days old)
> > References  : http://marc.info/?l=linux-kernel&m=124038280020950&w=4
> 
> I saw this warning with certain GCC versions for several kernel 
> cycles, so it's not any recent change that triggers this and it is 
> not a regression.
> 
> GCC is simply wrong here - i have posted a workaround for that but 
> it is too ugly to be merged upstream.
> 
> > Handled-By  : Andi Kleen <andi@firstfloor.org>
> > Patch               : http://patchwork.kernel.org/patch/19330/
> >               http://patchwork.kernel.org/patch/19406/
> 
> This patch regresses on older GCC versions and doesnt really address 
> the GCC false positive warning either, it just removes the inline 
> function that triggers the warning.

Note You need to log in before you can comment on or make changes to this bug.