Bug 13177 - 2.6.30-rc2-git7 build problem
2.6.30-rc2-git7 build problem
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-25 19:46 UTC by Rafael J. Wysocki
Modified: 2009-10-06 20:42 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.30-rc2-git7
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-25 19:46:38 UTC
Subject    : 2.6.30-rc30-git7 build problem
Submitter  : Martin Knoblauch <spamtrap@knobisoft.de>
Date       : 2009-04-21 13:39
References : http://marc.info/?l=linux-kernel&m=124032163602132&w=4

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-04-28 22:05:11 UTC
References : http://lkml.org/lkml/2009/4/27/56
Comment 2 Rafael J. Wysocki 2009-05-18 17:27:38 UTC
On Monday 18 May 2009, Martin Knoblauch wrote:
> 
> ----- Original Message ----
> > From: Rafael J. Wysocki <rjw@sisk.pl>
> > To: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
> > Cc: Kernel Testers List <kernel-testers@vger.kernel.org>; Martin Knoblauch <spamtrap@knobisoft.de>
> > Sent: Saturday, May 16, 2009 9:20:40 PM
> > Subject: [Bug #13177] 2.6.30-rc2-git7 build problem
> > 
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.29.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry    : http://bugzilla.kernel.org/show_bug.cgi?id=13177
> > Subject        : 2.6.30-rc2-git7 build problem
> > Submitter    : Martin Knoblauch 
> > Date        : 2009-04-21 13:39 (26 days old)
> > References    : http://marc.info/?l=linux-kernel&m=124032163602132&w=4
> >           http://lkml.org/lkml/2009/4/27/56
> 
>  Still a problem in 2.6.30-rc6-git3. Adding maintainer
> 
> BUILD   arch/x86/boot/bzImage
> Root device is (104, 3)
> Setup is 12664 bytes (padded to 12800 bytes).
> System is 2648 kB
> CRC 91a1a400
> Kernel: arch/x86/boot/bzImage is ready  (#2)
>   Building modules, stage 2.
>   MODPOST 471 modules
> WARNING: drivers/gpu/drm/i915/i915.o(.text+0x1313e): Section mismatch in reference from the function intel_lvds_init() to the variable .init.data:intel_no_lvds
> The function intel_lvds_init() references
> the variable __initdata intel_no_lvds.
> This is often because intel_lvds_init lacks a __initdata
> annotation or the annotation of intel_no_lvds is wrong.
> 
> ERROR: ".L192" [drivers/usb/serial/kl5kusb105.ko] undefined!
> make[1]: *** [__modpost] Error 1
> make: *** [modules] Error 2
Comment 3 Rafael J. Wysocki 2009-05-23 00:05:17 UTC
On Friday 22 May 2009, Linus Torvalds wrote:
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13177
> > Subject		: 2.6.30-rc2-git7 build problem
> > Submitter	: Martin Knoblauch <spamtrap@knobisoft.de>
> > Date		: 2009-04-21 13:39 (26 days old)
> > References	: http://marc.info/?l=linux-kernel&m=124032163602132&w=4
> > 		  http://lkml.org/lkml/2009/4/27/56
> 
> This one really looks like a compiler bug (the undefined symbol is an 
> internal gcc one: ".L192"). And the driver that gets it (kl5kusb105) has 
> not actually had any changes since 2.6.29 - although header files that it 
> includes obviously do have some, so it's entirely possible that some 
> infrastructure change causes it to trigger.
> 
> Martin hit another bug with his compiler (an ICE in gcc, fixed by commit 
> 26a9a418237c0b06528941bca693c49c8d97edbe), which is why I'm so willing to 
> blame that.
Comment 4 Marc Bejarano 2009-10-06 20:42:55 UTC
so are we just giving up on support for widely-used compilers that are out in the wild?

i hit this with:
===
[beej@dell ~]$ more /etc/redhat-release 
CentOS release 4.3 (Final)
[beej@dell ~]$ gcc --version
gcc (GCC) 3.4.5 20051201 (Red Hat 3.4.5-2)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
===

though the obvious workaround of unsetting USB_SERIAL_KLSI in .config exists, the myriad users of this compiler used to be able to compile a kernel.org kernel  without jumping through hoops :(

Note You need to log in before you can comment on or make changes to this bug.