Bug 13171 - 2.6.30-rc2 + xorg-intel-2.7.0 + DRM_I915_KMS = corruption
2.6.30-rc2 + xorg-intel-2.7.0 + DRM_I915_KMS = corruption
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-25 19:12 UTC by Rafael J. Wysocki
Modified: 2009-05-25 23:23 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.30-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-25 19:12:23 UTC
Subject    : 2.6.30-rc2 + xorg-intel-2.7.0 + DRM_I915_KMS = corruption
Submitter  : Alex Bennee <kernel-hacker@bennee.com>
Date       : 2009-04-19 6:27
References : http://marc.info/?l=linux-kernel&m=124022460014812&w=4

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Alex Bennee 2009-05-17 17:50:37 UTC
This bug has additional info on the freedesktop buzilla:

https://bugs.freedesktop.org/show_bug.cgi?id=21480

The core problem seems to be that when running in KMS X is unable to
allocate any memory and from that point everything else is doomed to
fail.
Comment 2 Rafael J. Wysocki 2009-05-17 18:09:42 UTC
References : https://bugs.freedesktop.org/show_bug.cgi?id=21480
Comment 3 Alex Bennee 2009-05-25 08:38:26 UTC
Tested on RC7 and I can now boot X and get some sort of display. I have other problems with KMS but I think this bug can be cleared now.
Comment 4 Rafael J. Wysocki 2009-05-25 23:22:49 UTC
On Monday 25 May 2009, Alex Bennee wrote:
> 2009/5/24 Rafael J. Wysocki <rjw@sisk.pl>:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.29.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=13171
> > Subject         : 2.6.30-rc2 + xorg-intel-2.7.0 + DRM_I915_KMS = corruption
> > Submitter       : Alex Bennee <kernel-hacker@bennee.com>
> > Date            : 2009-04-19 6:27 (36 days old)
> > References      : http://marc.info/?l=linux-kernel&m=124022460014812&w=4
> >                  https://bugs.freedesktop.org/show_bug.cgi?id=21480
> >
> 
> I've tested on the latest rc7 kernel and can now boot into the X with
> KMS enabled. I believe that's probably good enough for this regression
> to be cleared.

Note You need to log in before you can comment on or make changes to this bug.