Bug 13168 - ath5k fails to associate with AP
ath5k fails to associate with AP
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 normal
Assigned To: networking_wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-25 14:04 UTC by Thomas Meyer
Modified: 2009-04-29 18:02 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.30-rc3
Tree: Mainline
Regression: Yes


Attachments
config file (68.41 KB, text/plain)
2009-04-25 14:08 UTC, Thomas Meyer
Details
dmesg (58.93 KB, text/plain)
2009-04-25 14:12 UTC, Thomas Meyer
Details

Description Thomas Meyer 2009-04-25 14:04:42 UTC
Don't know why. 2.6.29.1 works fine.

dmesg and config attached.
Comment 1 Thomas Meyer 2009-04-25 14:08:50 UTC
Created attachment 21116 [details]
config file
Comment 2 Thomas Meyer 2009-04-25 14:12:00 UTC
Created attachment 21117 [details]
dmesg

I unloaded ath5k module later, because the NetworkManager seemed to scan through all available frequencies again and again. This scanning used a lot of cpu.
Comment 3 Bob Copeland 2009-04-29 16:04:46 UTC
Thanks for the report.  I didn't see any association request -- I wonder if scan time is now exceeding network manager's built-in timeout.  Any chance you could bisect just the changes in drivers/net/wireless/ath5k between 2.6.29 and 2.6.30 to see what broke?

Other possible things to try: configure wpa_supplicant to only scan a subset of the available frequencies, or try this patch:

http://marc.info/?l=linux-wireless&m=123841474910111&w=2
Comment 4 Thomas Meyer 2009-04-29 17:47:47 UTC
linked to patch fixes this bug for me!
Thanks. Will this patch go into linus' tree?
Comment 5 John W. Linville 2009-04-29 18:02:35 UTC
It is currently queued for 2.6.31...

Note You need to log in before you can comment on or make changes to this bug.