Bug 13165 - 2.6.30-rc3 : Regression: i915 , video
2.6.30-rc3 : Regression: i915 , video
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: acpi_power-video
:
: 13048 (view as bug list)
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-25 11:30 UTC by Rafael J. Wysocki
Modified: 2009-06-04 12:00 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.30-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-25 11:30:05 UTC
Subject    : 2.6.30-rc3 : Regression: i915 , video
Submitter  : We La <w.landgraf@yahoo.com>
Date       : 2009-04-23 19:19
References : http://marc.info/?l=linux-kernel&m=124051473119134&w=4
References : http://marc.info/?l=linux-kernel&m=124062673404329&w=4
Handled-By : Len Brown <lenb@kernel.org>
Patch      : http://patchwork.kernel.org/patch/18420/

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-04-25 19:17:51 UTC
Notify-Also : Soeren Sonnenburg <sonne@debian.org>
Comment 2 Rafael J. Wysocki 2009-04-26 12:05:23 UTC
On Sunday 26 April 2009, We La wrote:
> 
> The patch didnt yet enter into the -git of the main kernel.  Thus, the problem still is relevant.
Comment 3 ykzhao 2009-04-27 01:03:07 UTC
The issue can be fixed by the patch in http://patchwork.kernel.org/patch/18420/. But a new issue will be triggered.

The issue can be fixed by the following patch:
   http://marc.info/?l=linux-acpi&m=124058818318025&w=2

Thanks.
Comment 4 Zhang Rui 2009-05-05 02:12:53 UTC
*** Bug 13048 has been marked as a duplicate of this bug. ***
Comment 5 Rafael J. Wysocki 2009-05-13 09:29:55 UTC
Handled-By : Len Brown <len.brown@intel.com>
Patch : http://marc.info/?l=linux-acpi&m=124058818318025&w=2
Comment 6 Rafael J. Wysocki 2009-05-13 09:32:17 UTC
References : http://marc.info/?l=linux-kernel&m=124114670216455&w=4
Comment 8 Len Brown 2009-05-18 16:25:59 UTC
shipped in linux-2.6.30-rc6-git1
Comment 9 Matej Laitl 2009-06-04 12:00:14 UTC
Well,
for me ACPI_VIDEO newer worked alright and caused hardware backlight control not to work properly. However, I was happy with DRM_I915, ACPI enabled and ACPI_VIDEO disabled in .30-rc7 (no build problems here(?)). So commit 31db5645bda24682dadbc97d5e8a7918ade2a298 broke my setup. I wonder whether ACPI_VIDEO is really needed by DRM_I915. Could it be made optional?

The proper solution to this may be fixing acpi-video to work here (Fujitsu-Siemens M9400 laptop with Intel GM965 gpu), but I've never had a use for it, so it's not relevant for me.

Note You need to log in before you can comment on or make changes to this bug.