Bug 13154 - iwlagn soft lock-up
iwlagn soft lock-up
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 normal
Assigned To: Reinette Chatre
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-22 22:12 UTC by Panagiotis Papadakos
Modified: 2009-04-27 14:54 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30-rc{2,3}
Tree: Mainline
Regression: Yes


Attachments
TX debug patch (2.28 KB, patch)
2009-04-22 23:31 UTC, Reinette Chatre
Details | Diff
DMA fixes (18.68 KB, patch)
2009-04-22 23:34 UTC, Reinette Chatre
Details | Diff

Description Panagiotis Papadakos 2009-04-22 22:12:59 UTC
I have tried linux kernels 2.6.30-rc2 and 2.6.30-rc3 and both of them
lock-up when I try to connect using my wireless card (using WEP).
Pressing the power button halts normally my laptop.
This is on an amd64 system with Intel Wireless WiFi Link 4965AGN.

I can't find any weird messages in the logs.

2.6.29 works fine.
Comment 1 Reinette Chatre 2009-04-22 23:31:45 UTC
Created attachment 21086 [details]
TX debug patch
Comment 2 Reinette Chatre 2009-04-22 23:34:03 UTC
Created attachment 21087 [details]
DMA fixes

As a sanity check, could you please try this patch and the one before it (the DMA fixes depends on the TX debug patch)?

If those do not solve you problem, could you please help us obtain more information?

It sounds as though you can predict exactly when the problem occurs (when you connect using WEP) ... could you please do the following:

- please check if you can reproduce the problem when in console mode - do you perhaps have a serial console? if not, perhaps netconsole?

- set up syslog to log kernel messages to a file. Something like the following in syslog.conf:
kern.*                       /var/log/kern.log

- ensure your driver is compiled with debug support (CONFIG_IWLWIFI_DEBUG is set). You can verify that the driver is compiled with debug support if it as a "d" in the version number printed during module probe.
- right before you trigger the problem please run:
echo 0x443fff > /sys/class/net/wlan0/device/debug_level
- trigger the problem
- use sysrq key to get information on locks being held ('d'), as well as all task information ('t'), dump blocked tasks ('w').

When you restart, please check your log file (/var/log/kern.log) for debug and post here. I hope that you can get serial console access to get us the sysrq dumps also.

Thanks!
Comment 3 Panagiotis Papadakos 2009-04-27 13:12:36 UTC
I just compiled 2.6.30-rc3-git2 and it seems that now iwlagn works just fine.
The problem was not restricted though only to WEP connections, but it also happened with public networks.

Note You need to log in before you can comment on or make changes to this bug.